PDA

View Full Version : Echo Hedge Clip Binding


Stuttering Stan
05-21-2005, 09:44 PM
Echo Hc1500, The Blades Bind When Give It Gas, Like There Is A Problem In The Gear Box, It Is A Sealed Unit So How Do I Remedy This.

ed2hess
05-21-2005, 10:33 PM
It is the screws that hold the blades together. Just loosen the nuts and back out the screw a little and then check to be sure the blades have about .005 clearance. Then hold the screw and tighten the nut back tight. This is a real BAD design by ECHO ....I like their trimmers due to light weight but we had the same problem on the new articulating unit yesterday.

Stuttering Stan
05-22-2005, 12:17 PM
Done that with the same results, any other ideas. The gears are not turning but the engine is bogging down, could it be too much grease?

BCSteel
05-22-2005, 12:42 PM
Echos use small roller bearings in the gear box, theres about 50 or so of them in there. Was it making any noise before it stopped working? There could be a missing/broken one in there jammed up some where. Once one comes out the rest tend to cause problems fast when they come loose.

stumper1620
05-22-2005, 01:49 PM
pour some bar & chain oil on the blades and see what happens.

PR Fect
05-22-2005, 02:04 PM
pour some bar & chain oil on the blades and see what happens.
Don't know what bar and chain oil will do to the shrubs. We use Pam or some other canola oil cooking spray. It works like a charm.

stumper1620
05-22-2005, 02:07 PM
Don't know what bar and chain oil will do to the shrubs. We use Pam or some other canola oil cooking spray. It works like a charm.
well, I haven't killed anything yet. at least i don't think I have. :D

BCSteel
05-22-2005, 05:50 PM
pour some bar & chain oil on the blades and see what happens.

Thatsb what I use too. He already said its not the blades binding though.