PDA

View Full Version : Kawasaki 5 HP engine hard to start when hot


sethsodsquad
05-29-2005, 01:51 PM
My Kawasaki 5 HP engine on my Snapper Commercial 21" mower has been hard to start after it has been run for 30 minutes or so. In other words, when the engine is hot, it is hard to start.

It starts on the first pull with no trouble when the engine is cold, but it takes about 10 pulls to start it when it is warm.

I called my dealer and he said it might be the ignition coil or the valves need to be adjusted.

Anything else that it might be? I cleaned out the carburetor, fuel filter, and fuel line and that didn't help.

Seth Goings

Restrorob
05-29-2005, 05:18 PM
My Kawasaki 5 HP engine on my Snapper Commercial 21" mower has been hard to start after it has been run for 30 minutes or so. In other words, when the engine is hot, it is hard to start.

It starts on the first pull with no trouble when the engine is cold, but it takes about 10 pulls to start it when it is warm.

I called my dealer and he said it might be the ignition coil or the valves need to be adjusted.

Anything else that it might be? I cleaned out the carburetor, fuel filter, and fuel line and that didn't help.

Seth Goings

Start the engine and run it till it warms up,Then turn it off and take a spare plug and put it in the plug wire,Ground it to a head or valve cover bolt and have somebody pull it over and check for spark. This will tell you if its the coil,If it has spark then I'd check valve adjustment.
Are you choking this engine when its hot ?

sethsodsquad
05-29-2005, 10:12 PM
Ill check what you said - I have tried choking and not choking when it is hot - it doesn't seem to make a difference. Choking makes it almost impossible to start.

Seth