PDA

View Full Version : Kubota commercial 5 hp ohv won't start


evan price
06-13-2005, 06:07 PM
Kubota 5 hp ohv mower. (Got two of these big heavy sob's) One of my guys was using it and said it just shut off. Won't start. Got good spark. Got fuel (plug wet when I pull it). Flywheel key is fine. Valves are opening and closing as normal. Compression seems low. Pulled valve cover, compression release device of some kind inside the motor is bumping intake valve when I turn motor over like I assume it should be- or shouldn't it be? Is it stuck? How do I fix this?

Wish I never bought these things because the clutch for the blade is a PITA & they weigh like 5000 lbs & so far haven't been more reliable than a $99 cheapy. Thanks.

txlawnking
06-13-2005, 07:26 PM
Did you check for water in the fuel?

Restrorob
06-13-2005, 09:23 PM
Kubota 5 hp ohv mower. (Got two of these big heavy sob's) One of my guys was using it and said it just shut off. Won't start. Got good spark. Got fuel (plug wet when I pull it). Flywheel key is fine. Valves are opening and closing as normal. Compression seems low. Pulled valve cover, compression release device of some kind inside the motor is bumping intake valve when I turn motor over like I assume it should be- or shouldn't it be? Is it stuck? How do I fix this?

Wish I never bought these things because the clutch for the blade is a PITA & they weigh like 5000 lbs & so far haven't been more reliable than a $99 cheapy. Thanks.

I hope you have your valves mixed up,Most compression releases are on the exhaust valve. Post the model and spec. numbers off the engine and we will see what we can come up with.