PDA

View Full Version : Driver Side Taillight


RedWingsDet
07-31-2005, 10:28 AM
The driverside rear light wont work at all, or the turn signal, on my trailer. Its an enclosed haulmark. I replaced the entire assembly and it still wont work. Everything else works execpt the rear driverside.

Can anyone help?

RedWingsDet
07-31-2005, 11:22 AM
when headlamps are on, the taillights are on, but the driverside still wont blink or brake

UNISCAPER
07-31-2005, 12:54 PM
Check all the connection points and run it back to the source. Startat the point where you connected the back light to those wires. I don't know Haulmark trailers, but on a Wells Cargo trailer, you have two junction boxes. One at the tongue, the other at the trailer rear, inside. Remove those ccovers and poke your test light into the wire nuts (Not the wire themselves) with a good ground and see if you have juice. If not, go to the front junction box do the same. If no juice remove the trailer plug and test the outlets on the truck. I'm betting somewhere, some how, you have some corrosion, or maybe a loose wire. now, assume you have current at the back junction but nothing to the light....Your problem is between the light and the back box. Do the same proceedure for each area you test if there is no current. You just need to pinpoint where the current stops and it does not matter the sequence, if you want start at the trailer plug.

I got me a yuppie device some years ago that works like a Gieger counter and all you do is insert the sender to a fuse holder, then run the wand along the wire path...It will start beeping faster and faster until you find the open or short. I give the device the SNS (slicker than snot) rating of approval and a must have for all who have trailers/trucks....

Restrorob
07-31-2005, 10:26 PM
Ok, Where can I get one of these yuppie devices and whats something like that cost ? It sounds like a real time saver !

UNISCAPER
07-31-2005, 10:56 PM
I'll get you a manufacturer and some numbers. It's at my shop in the toolbox.

Restrorob
08-01-2005, 07:50 AM
I'll get you a manufacturer and some numbers. It's at my shop in the toolbox.

Thanks alot !

DLCS
08-01-2005, 11:51 AM
Didn't you just buy that trailer new? Does it have a warrenty?

sildoc
08-01-2005, 12:43 PM
it is the bulb. From what you explained that when the lights are on it is lit but it wont blink or brake. The bulb has two filiments in it. One for the head/tail lights and one for brake and blinker. A 75 cent fix and 3 min.

RedWingsDet
08-01-2005, 01:05 PM
I replaced it. and still same problem... and yes it has a waranty. but why should I take it in for service and have to wait a week, when I can do it myself in a few minutes?

i_plant_art
08-01-2005, 01:29 PM
have u tried checking the fuses in the truck? if the fuse is blown out for that circuit then it wont work........ also track the wires under the trailer and make sure they are not touching the frame anywhere. this would be what would cause the fuse to blow out.

sheshovel
08-01-2005, 02:20 PM
By working on it yourself,you can void your warranty in most cases.So with new equipment...try not to work on it yourself,obviously you have already spent more than a few minutes on it.If you do end up taking it in,don't tell them you worked on it.

RedWingsDet
08-01-2005, 03:15 PM
By working on it yourself,you can void your warranty in most cases.So with new equipment...try not to work on it yourself,obviously you have already spent more than a few minutes on it.If you do end up taking it in,don't tell them you worked on it.

only thing I did was change a light. lol I dont think that could void the waranty. if so, then im never buying a haulmark again...

I honestly dont even think im going to get it fixed. It doesnt bother me that much

DLCS
08-01-2005, 04:21 PM
only thing I did was change a light. lol I dont think that could void the waranty. if so, then im never buying a haulmark again...

I honestly dont even think im going to get it fixed. It doesnt bother me that much

Get it fixed, you don't want to get stopped for a lousy turnsignal not working do you? What kind of plug do you have on your truck, 7 way rv or the round style? I always had trouble with the round plugs, uaually the wires inside the connectors would corrode and break due to the metel srewws inside them.

RedWingsDet
08-01-2005, 06:23 PM
Get it fixed, you don't want to get stopped for a lousy turnsignal not working do you? What kind of plug do you have on your truck, 7 way rv or the round style? I always had trouble with the round plugs, uaually the wires inside the connectors would corrode and break due to the metel srewws inside them.

yeah its the 7pin round style