PDA

View Full Version : is my hydro running slower?


LCME
08-19-2005, 01:22 PM
either i'm getting use to mowing at full speed or my exmark tthp hydro is slowing down. last couple of weeks while mowing at full speed. i notice my machine running slightly slower. no enough to really notice. but, just seems a little slower at full speed. if so, what could be the cause.

C&KLawnCare
08-19-2005, 01:44 PM
Make sure the throttle is going to wide open like it used to the clamp/ cable how ever it is set up on the machine . could cause a slight drop in Hydrulic speed .

Also check the levers and pivot points to make sure your not loosing travel to the speed control on the transmission(s) . It don't take much slop to slow a hydro down if the point from control to transmission is loosing travel

TURFLORD
08-19-2005, 02:12 PM
Get a new belt for the drive pumps.

MTR
08-19-2005, 02:23 PM
Is your hydro filter changed at least once a year or every 200-250 hrs? I have found that changing hydro filter help regain the "responsiveness" tremendously. It is not difficult, make sure that you use 15-50 mibil one, and eXmark hydro filter, also make sure fill up the new filter to brimming before installing, following procedure in manual and you will be fine. My 52" TTHP fly like crazy since it gets new filter and oil, make sure you bleed the system out of air bubble by running for good 15 min before putting it in the field again. Love that TTHP...

TClawn
08-19-2005, 02:29 PM
I had this happen, and my throttel was slipping down. I now use wrap a piece of wiring around the fuel shut off when I reach the desired rpm.

also, if you did not change your hydro fluid right, you could experience a temporary slow down.

did you put the right oil in if you changed it? if not, stop NOW. do not run it.if not, prolly still the throttle.

i_plant_art
08-20-2005, 12:01 AM
if the trrottle is slipping some then why tie it up just get a wrench and look under the controls (aka dashboard as we call it ) and tighten the throttle a little... the bolts that hold the level in the same position come loose from the vibration from time to time, this will cause the slippage.

BobcatZT
08-20-2005, 12:04 AM
We had the same problem with our Bobcat rider. A week after noticing the slowdown, one of the hydro pumps went bad. Not saying that is the problem on your mower, just mentioning it.