PDA

View Full Version : Exmark throttle cable....


nobagger
09-27-2005, 10:09 PM
Anyone ever had a throttle cable snap on a brand new Exmark before? This makes problem #3 for this "great mower". :realmad: And it has at most 40hrs on it. Problem #1-set screws fell out of tensioner pullies. Problem #2- ECS handel would not release causing it to go in circles. Problem #3- While on our second lawn the throttle cable became harder to push then would not move all together. Its a Metro 36" HP and of course the dealer does not have one so I'm out a mower for who knows how long! :angry: :angry:

Cigarcop
09-27-2005, 10:29 PM
nobagger,

Where you at or near in PA, if your anywhere near Pottstown / Gilbertsville you could try at Passmore.

http://www.passmoreservice.com/

dvmcmrhp52
09-27-2005, 11:15 PM
Now, if you're done with all the drama................
Why will you be "out a mower" for who knows how long?
You haven't mentioned anything of a serious nature.


New machines as well as old need to be adjusted and lubed and set up and......................


If Exmarks are so bad, why do you have 2 others?

nobagger
09-28-2005, 10:56 PM
Now, if you're done with all the drama................
Why will you be "out a mower" for who knows how long?
You haven't mentioned anything of a serious nature.


New machines as well as old need to be adjusted and lubed and set up and......................


If Exmarks are so bad, why do you have 2 others?
Drama? no! lack of productivity!! We do not have the 52" anymore and the 48" was my first commercial w/b and I bought it used its probably at least 10 years old and it runs great so I thought this brand new Exmark would follow in its foot steps, but I guess not. Its going to be at least 3 days before repairs are done so they tell me. They just sold their demo/loaner mowers so yeah I'm stuck doing smaller props. with a 21" or two. Thats B.S.!!

MTR
09-28-2005, 11:38 PM
Drama? no! lack of productivity!! We do not have the 52" anymore and the 48" was my first commercial w/b and I bought it used its probably at least 10 years old and it runs great so I thought this brand new Exmark would follow in its foot steps, but I guess not. Its going to be at least 3 days before repairs are done so they tell me. They just sold their demo/loaner mowers so yeah I'm stuck doing smaller props. with a 21" or two. Thats B.S.!!

I am in your shoes before so I know exactly where you're coming from...so long eXmark new line-up. This year 05 has been sucky sucky for any of its new mowers...quality-related problems are crawling everywhere. In my area, it is even worse cause once you down your main Z or wb you are finished for like 3 weeks! Don't you notice their dealership is dwindling every minute and they don't care to talk to you those who stopped carrying them! just hung up the phone.... I am through...with X, you will hear people complained like...
cable snapped or stuck, engine blew, pulley out of syn from factory, belt snapped, hydro leak, gasket blown, some bolts fell off without any tightening, and of course ECS handle is not returning so you spinning like crazy, adjustment tracking knob fell off after trying to adjust left ...what a joke.

dvmcmrhp52
09-29-2005, 12:03 AM
Drama? no! lack of productivity!! We do not have the 52" anymore and the 48" was my first commercial w/b and I bought it used its probably at least 10 years old and it runs great so I thought this brand new Exmark would follow in its foot steps, but I guess not. Its going to be at least 3 days before repairs are done so they tell me. They just sold their demo/loaner mowers so yeah I'm stuck doing smaller props. with a 21" or two. Thats B.S.!!



3 days to fix a throttle cable. I don't think so.

dvmcmrhp52
09-29-2005, 12:05 AM
I am in your shoes before so I know exactly where you're coming from...so long eXmark new line-up. This year 05 has been sucky sucky for any of its new mowers...quality-related problems are crawling everywhere. In my area, it is even worse cause once you down your main Z or wb you are finished for like 3 weeks! Don't you notice their dealership is dwindling every minute and they don't care to talk to you those who stopped carrying them! just hung up the phone.... I am through...with X, you will hear people complained like...
cable snapped or stuck, engine blew, pulley out of syn from factory, belt snapped, hydro leak, gasket blown, some bolts fell off without any tightening, and of course ECS handle is not returning so you spinning like crazy, adjustment tracking knob fell off after trying to adjust left ...what a joke.



For someone who's only doing it for three years and only has one Exmark you sure seem to have an opinion.