PDA

View Full Version : 81 brakes and steering


farmboy4
03-28-2001, 09:56 PM
I have an '81 k 30 (454)that has some week brakes and poor powersteering. (I realized the brakes close to home today while pulling a trailer well over 10 k) The power steering pump is like the ones used on 2 ton trucks so the brakes are boosted by the powersteering pump i believe. the front brakes appear to be fine as they lock up. The pads have been replace recently and they have fluid. The powersteering is also week. It is fine at times but is as good as not having any at all at other times. It to has fluid. I am not sure what the problem is. Anyone have any ideas.
thanks in advance

Alan
03-28-2001, 11:49 PM
The hydraboost won't work right unles syou have hydraulic pressure from the pump. The power steering won't work right unless you have pressure from the pump. Even if the pump is full of oil it's not going to work right if the belt is bad or out of adjustment. The only power steering pump I've ever had fail was pretty easy to diagnose, it siezed solid and the belts were smoking trying to turn it. Other than that, I would tend to think that if the pump fails it's GONE, no intermittent operation, so once again it's down to belts. Easy to overlook and even if they are tightend correctly they could be worn and running in the bottom of the groove. Does the same belt(s) run the water pump as well? How's you coolant temperature running? If it's leaning towards the hot end that's another sign of belt troubles.