PDA

View Full Version : Lesco Broadcast Clicking Noise


drsogr
03-07-2006, 05:28 PM
The lesco broadcast spreader that I just bought is making a clicking noise...is this normal?

drsogr
03-07-2006, 06:06 PM
I figured it out. It was the agitator rubbing up against the impeller. For some reason the impeller shaft had slipped. I pushed the holder back in place.

Jason Rose
03-07-2006, 06:43 PM
Yeah, mine does the same thing, only my old one has 2 of those clicking problems... 1 was the agitator deal underneath, that was an easy fix. The other is that when I have the 3rd hole shut off the tab on the end of the slider catches the impeller.

I just bought a NEW lesco spreader a last monday at their open house with the remote kit on it. So far all I've used it on is my lawn, I think I like it! lol

If we didn't have the wind today I was going to start doing some apps. There are still a lot of lawns I want to mow off shorter and clean-up before I spread my fert though! Thank goodness it's been warm!

drsogr
03-07-2006, 10:00 PM
ARGH! I bought mine today and it didn't have the remote kit. So they sent it with me and told me they would charge me $60 to put it on. I ended up returning the darn thing because of the horrible instructions. I couldn't even decipher the picture it came with.

I really like the spreader but the sheild with the 3rd hole thing pissed me. I wish mine would have just been on there already. Yours actually had it on there when you bought it?

I am going to order one from lesco just like the one that is in the manual...since I know the instructions are good for it. The agitator thing...I put it back together and it worked fine...and then it started coming apart again. It needs a sprink clip or something.

DUSTYCEDAR
03-07-2006, 10:11 PM
just bend it up so it doesent rub

Jason Rose
03-07-2006, 10:32 PM
ARGH! I bought mine today and it didn't have the remote kit. So they sent it with me and told me they would charge me $60 to put it on. I ended up returning the darn thing because of the horrible instructions. I couldn't even decipher the picture it came with.

I really like the spreader but the sheild with the 3rd hole thing pissed me. I wish mine would have just been on there already. Yours actually had it on there when you bought it?

I am going to order one from lesco just like the one that is in the manual...since I know the instructions are good for it. The agitator thing...I put it back together and it worked fine...and then it started coming apart again. It needs a sprink clip or something.

No no... My remote kit came in a cardboard box too... Was your partly assembeled in the box? Like the bolts/nuts and spacers and washers were in their respective places but just loose? I know they used to come just all in peices and yes, they were almost impossible to assemble with little to no instructions so someone decided to pre assemble them from the factory somewhat...

I didn't have any troubles with mine at all actually. Compared to my other spreader I put the kit on 4 years ago (differnet design) this new one was a breeze!

If you need some pics of it assembled I could try to take some. I don't know how much my photography would help out though, lol I'm not sure that they sell them set up already. Heck for $50 i'd be glad to set yours up for ya!

somo1
03-07-2006, 11:29 PM
Sounds like with all the problems that you guys are having with Lesco spreaders, I would just by an Andersons. About $400-500 in stainless steal. The only complaint that I have are that the rain covers wear out in about a year. Great spreader, even coverage both directions and easy to use.

Jason Rose
03-07-2006, 11:39 PM
Well these aren't problems. Nothing is broken, just not adjusted properly. Manily it's because they are assembled at the store and attention to details is lacking at times during assembly.

Does your "andersons" spreader have a kit to allow you to spread edges like the Lesco spreaders do? If so, is it more than just a flip down deflector? Lescos are a lot more too them than that. Like anything with moving parts and adjustable linkages it takes some adjustments to get everything set right. Oh, and the Lescos are stainless steel too and are also $300 (on sale) for the spreader + $90 for the remote deflector kit. Many people don't get the deflector kit but I like mine and use it a lot.

Mr.Mow-It-All
03-08-2006, 02:11 AM
Just bought mine a couple days ago and it was all on there, the 3rd hole, and shield. Love it, works great. The cable for the 3rd hole does get in the way of the agitator sometimes, but I just move it and it is ok. I don't know if I paid for the instal or not, but to have both kits on there it was $89 more tha the basic model, and well worth it.

drsogr
03-08-2006, 08:00 AM
No no... My remote kit came in a cardboard box too... Was your partly assembeled in the box? Like the bolts/nuts and spacers and washers were in their respective places but just loose? I know they used to come just all in peices and yes, they were almost impossible to assemble with little to no instructions so someone decided to pre assemble them from the factory somewhat...

I didn't have any troubles with mine at all actually. Compared to my other spreader I put the kit on 4 years ago (differnet design) this new one was a breeze!

If you need some pics of it assembled I could try to take some. I don't know how much my photography would help out though, lol I'm not sure that they sell them set up already. Heck for $50 i'd be glad to set yours up for ya!

No mine were just all in pieces. The nuts in bolts were not in their respective places. And the instructions were junk. He showed me an example where they were all put together....but the one I had was just a mess. Do you happen to know what part number yours was?

drsogr
03-08-2006, 08:07 AM
Just bought mine a couple days ago and it was all on there, the 3rd hole, and shield. Love it, works great. The cable for the 3rd hole does get in the way of the agitator sometimes, but I just move it and it is ok. I don't know if I paid for the instal or not, but to have both kits on there it was $89 more tha the basic model, and well worth it.

I wish mine had come like this.

Jason Rose
03-08-2006, 08:41 AM
No mine were just all in pieces. The nuts in bolts were not in their respective places. And the instructions were junk. He showed me an example where they were all put together....but the one I had was just a mess. Do you happen to know what part number yours was?

Oh man, that sucks! Yeah without having a working model to look off of it would be very tough to assemble one of those with the instruction sheet they have. Just make sure they DID give you the right kit! The ones for the old spreaders were set up differently and often didn't come pre assembled either.

Item number on my ticket for that was 706667, it was called a "Kit deflector remote 3rd hole 80# 2001"

drsogr
03-08-2006, 08:53 AM
Yeah that was the kit I had....it was just not preassembled.

drsogr
03-08-2006, 09:58 AM
Well I called them and talked to them about it....he told me that some come preassembled and some don't. I told him that I wanted one that was preassembled. He told me he would put one together....I am doubtful...but I will wait and see. I am heading up to K.C. here in a couple weeks I will get one up there if I have to.