PDA

View Full Version : Truck Problems!


FearThisDeere
05-11-2006, 08:12 AM
I just bought this 1987 dodge Ram W150 4x4 318 carbed a few weeks back. I bought it as a beater mudding truck, but now it has turned into a project truck!:dancing: The main issue right now is that is won't start. The last time I drove it, it died on me twice, so I rushed home and parked it. Now it won't start. Still seems to be getting fuel to the carb. It cranks, just won't turn over. It has all new distributor, plugs, and wires along with everything else you could think of. What should I look for? Also, with a full tank of gas, it leaks under pressure pretty good. There is no leak in the tank snd it does not always happen. Could it be something like the fuel pickup ring on top of the tank (I think that's what it is called??)? Finally, it has very loose steering above 45 MPH. All the pitman arms, control arms, ball joints, and idler arms have been replaced, but it is still loose. I would say that it is about 25 degrees off give or take. Has anyone tried using urethane bushings? How did they work? Would they fix this problem? Are they easy to install for someone that is not that skilled or would it be easier to take it to the shop? I have heard many good things about them. Thanks for any help in advance. I just don't know too much on this truck or how to work on it.:hammerhead:

sgrprincees
05-11-2006, 01:11 PM
I have a 1989 Dodge W100 318 TBI, and I just took it to the dealer because it only ran right at full throttle, otherwise sputtering and stalling. Apparently the timing was off. The steering shafts on these trucks very commonly wear out (actually the joint at the bottom where they connect to the steering box.) The lasting fix is to buy a Borgeson shaft for about $200.

FearThisDeere
05-11-2006, 06:12 PM
Before mine died, it would sputter from time to time when it was under load... like when I really stomped on it. It had a rough idle when I bought it, but some fresh gas cleared that up without a problem. Would the timing all of a sudden make it not turn over when it has turned over fine for weeks? It was running when it died for good. I had it idling and all of a sudden it started to sputter... then there was nothing!:cry: I'll look into the steering shaft. Thanks!

oldrustycars
05-12-2006, 12:27 AM
did you check for spark at the plugs? check for fuel pressure at the carb? try a whiff of starting fluid and see if it starts, that "should" eliminate ignition problems. i highly suggest a Haynes service manual, 20 bucks at any auto parts. was the front end aligned after all the front end parts? if not, it should be.

FearThisDeere
05-12-2006, 08:19 AM
There is spark. I have not checked for fuel pressure yet or tried it with starting fluid. The truck sits outside and it has been raining for four days!!! The front end was aligned when all the new parts were put on according to the guy a bought it from. Would an alignment (or lack there of) cause loose steering? A Hayes Manual is definitely on the list of things to buy.

oldrustycars
05-12-2006, 10:19 AM
bad alignment will cause poor handling, and make the vehicle feel loose. it wont cause actual play in the steering. it will cause you to have to correct constantly, or follow every crack in the road.

FearThisDeere
05-12-2006, 04:51 PM
Well, the steering is very loose. It is like that even if I am just sitting and turning the wheel. Probably not the alignment.

oldrustycars
05-12-2006, 05:59 PM
Finally, it has very loose steering above 45 MPH.
if it has sloppy steering while standing still, have someone wiggle the steering wheel back and forth while you look and see where the play is. if the shaft is moving up to the steering box, but the pitman arm isnt moving, its in the steering box. ive had a few sloppy mopar boxes, they were about 150 a few years ago. i dont think there was anything you can adjust yourself. and as someone already suggested, check for a rag joint or something in the steering shaft. this much play should be fairly easy to spot.

Lawn Masters
05-13-2006, 03:42 PM
If your fuel pump to the carb is driven by the motor, specifically the camshaft, look at the fuel line, if there isnt a filter somewhere prior to that pump, it may have ingested some dirt and decided not to pump anymore. Also, look at your carburetor itself, possibly some dirt in there that caused it to stop running by cutting off fuel.

I had an old truck with the mechanical pump to the carb, that ingested some crap from the tank, and killed the pump on me. solution: put an inline filter on the fuel line before the pump, some genious designed mine so the filter was after the pump fastened into the carb.

FrankenScagMachines
05-13-2006, 03:48 PM
www.ramchargercentral.com the ultimate source for Dodge trucks! Go there and join up!!! I'm BushHogBoy over there...





What are you waiting on? GO!!!

FearThisDeere
05-17-2006, 10:38 AM
Thanks for all the help. I have had the flu for the last week (thanks god it rined every day!!!!) and now just gotta catch up on everything!