PDA

View Full Version : Excavator Hiccup?!?


bbailey
06-01-2006, 04:59 PM
Newer to the site but I hope you guys can help. 1997 Komatsu PC-35R8 excavator that recently while in use has twice lost power while running at full throttle. Once it died completely but it starts right back up and runs perfect and today it bogged down and almost died so I throttled it down and throttled it right back up and it ran ok. Real intermittent and does not seem to be affecting anything else. Fuel problem?????? Your help will be greatly appreciated! Thanks

Scag48
06-01-2006, 05:09 PM
First, I'd check your fuel filter. Maybe check your air filter, but usually a clogged air filter will make the machine bog down and produce black smoke, but it's worth a look anyway. My bet is that you either have a clogged fuel filter or you're getting air in the fuel line somewhere causing a nice little bubble. It's possible that when you restart the machine is purges the bubble out then let's air in again down the line.

PROCUT1
06-01-2006, 05:30 PM
Second to scag.....Def sounds like a fuel related issue. Begin at the tank and check connections, filters etc.....Also check water separator, on some they can get filled up with water if you dont drain them and then on occassion suck a little in the line.

Dirt Digger2
06-01-2006, 07:59 PM
we got that problem every now and again on our Volvo EC150...its not the fuel...its the onboard computer, its spurratic. It usually self diagnosis and fixes itself though.

minimax
06-02-2006, 10:10 AM
Cound be water in the fuel. Check the fuel bowl( maybe more than one bowl).look in the parts book for help finding the bowls.

TAF
06-02-2006, 12:54 PM
My PC40 did the same thing. Check your fuel filter, chances are it will have some debris in it. Next try to drain the tank with the petcock that should be located on the bottom of the tank. If it won't drain there you can be sure there is crud in the tank. Poke a wire up in it to see if you can get it to drain. I ended up removing the petcock and finding plenty of rust and crud. I then let the tank drain out and used a shop vac to clean out the tank completely. Now the machine runs great and I routinely open the petcock to keep any water of crud from building up. My machine was used and I am sure no one ever opened that petcock to keep water from accumulating. Also buy a few extra fuel filters cheap insurance.

bbailey
06-02-2006, 07:31 PM
Thanks TAF, I am going to try that tomorrow morning and I will let you know how it goes. I thought it was a fuel issue but wanted some backup from you guys. Thanks!

bbailey
06-05-2006, 04:47 PM
Changed the fuel filter and opened the petcock on the tank. I did not know that diesel fuel was black. LOL:dizzy: Drained off a gallon or so of fuel , until it got clean and fired her up. OK at this time. I do not think it had ever been drained! Thanks to all who put in their .02.