PDA

View Full Version : Briggs fuel pump problems


bbahun
06-14-2006, 09:51 PM
Took the carb apart to clean it on a 18.5 hp briggs & stratton Model 42A707. I put new springs and diaphram in the fuel pump, cleaned the float, needle, bowl and fuel passages with carb cleaner. I can't get the bowl to refil with fuel. If I refill it and put the carb back together it will run until it is empty. I can't figure out why it will not pull any fuel into the carb bowl. Any suggestions?:)

lawnmaniac883
06-14-2006, 10:05 PM
Did you put the diagraphm in backwards? Is the fuel valve turned on? Start with common sense stuff first.

Restrorob
06-14-2006, 10:13 PM
If you didn't get the two hoses mixed up you need to take the fuel pump back apart and make sure you got all three springs in the right place and the two small brass ones didn't move out of place while assembling.

fixer67
06-14-2006, 11:40 PM
If you didn't get the two hoses mixed up you need to take the fuel pump back apart and make sure you got all three springs in the right place and the two small brass ones didn't move out of place while assembling.

I always put a dab of grease on the small brass springs to hold them in place. Not much grease, just enough to "glue" them in place.

Restrorob
06-15-2006, 06:31 AM
I always put a dab of grease on the small brass springs to hold them in place. Not much grease, just enough to "glue" them in place.


Ditto, Same here.

bbahun
06-15-2006, 06:48 PM
Thanks guys! I tried the grease and it worked. Running great. Thanks for the help.