PDA

View Full Version : Echo SRM-260 Mystery


MDLawnman
07-04-2006, 09:50 PM
I have an Echo SRM-260 that has a problem that I can't figure out. Cold or hot the motor will bog down when I squeeze the throttle to get the string spinning. I've cleaned the plug, exhaust. gas and air filters. It's hard to start but if I move the choke around after it starts I can get it up to speed BUT IT WON'T STAY AT MAX SPEED UNLESS I TURN THE UNIT UPSIDE DOWN. I'm not kidding. If I rotate the unit upside down it will go to max throttle and stay there for less than a minute - then bog down again and shut off.

HELP!:help:

MowerMedic77
07-04-2006, 10:46 PM
Its a carb issue I have had lots of customers with this unit tell me they have purchased new carbs to rid their symptoms since I don't carry echo can't hook you up with the item# sorry

Jim@MilkyWay
07-04-2006, 10:59 PM
....if I move the choke around after it starts I can get it up to speed ....
IMHO you have a orifice in your carb stopped up.
Again Happy 4th to each and everyone.:usflag: :usflag: :usflag: :usflag:

lawnmaniac883
07-04-2006, 11:04 PM
Try this, take the air cleaner assy off and soak a rag in mixed gas. If you can get the unit started, hold the rag close to the intake while pulling the throttle trigger open at the same time. If the engine runs normal when doing this you need to rebuild/replace the carburetor.

MDLawnman
07-04-2006, 11:11 PM
Many thanks!

Bumblebee the mower
07-05-2006, 10:15 AM
Try taking the carb apart to the point of where you can still get it back together and soak it with carb cleaner. Let it set and dry out before you reassemble it. Next gas you buy use stabil fuel stabilizer in your gas, put it in when you buy the gas,dont wait and put it in later. It will make a difference in your equipment. I use it in all my equipment, but it makes the biggest difference in my boat It will keep your gas fresh for 6 months.

MDLawnman
07-05-2006, 06:09 PM
My dealer has always said to use at least mid grade gas and I do - sometimes high test if that's all that is available at the time. I'll try the gas stabilizer too.

thanks!

ed2hess
07-05-2006, 06:46 PM
You need to put a carb kit in if this unit has had a lot of usage. The alum nub that actuates the gas valve wears down and you don't get enough gas. This is also a symptom of getting air in system, is the unit leaking anywhere? If you decide to get a new carb be sure your replacement has the carb adjusting screw that came out last year. It will fit up fine with older units.

tallimeca
07-05-2006, 09:56 PM
if you are using the Echo brand oil, it has stabelizer in it. Also, Echo recommends using a minimum of 89 octane to maintain your warranty status.

MDLawnman
07-05-2006, 10:02 PM
As a matter of fact I do use the Echo oil! Thanks again!

watatrp
07-06-2006, 08:00 AM
Have you tried removing the spark arrester screen on the exhaust? I've done this in the past with great results. It gets carboned up over time and almost chokes the exhaust down.

bill w
07-06-2006, 08:17 AM
I have an Echo SRM-260 that has a problem that I can't figure out. Cold or hot the motor will bog down when I squeeze the throttle to get the string spinning. I've cleaned the plug, exhaust. gas and air filters. It's hard to start but if I move the choke around after it starts I can get it up to speed BUT IT WON'T STAY AT MAX SPEED UNLESS I TURN THE UNIT UPSIDE DOWN. I'm not kidding. If I rotate the unit upside down it will go to max throttle and stay there for less than a minute - then bog down again and shut off.

HELP!:help:


You cleaned the fuel filter?

I'd replace it and the fuel lines. Running when upside down sounds like an air leak to me.