PDA

View Full Version : Trimmer Technical Help


LushGreenLawn
07-14-2006, 06:17 PM
Hey Guys

I have an Echo SRM-2100 trimmer and a Weedeater Brand P.O.S that I bought earlier this year as a backup.

I noticed that my echo started to not get the tourqe it once got, and it seemed to kind of bog down. I also noticed that when it started to Bog down, it looks like air is being blown into the gas tank, the gas is kind of bubbling, like a kid blowing bubbles in milk. I had looked at the tank in the weedeater trimmer, and it did not have the bubble when it ran. The Echo trimmer is 7 years old.

Today, I noticed the weedeater brand doing the same thing, bogging down with air bubbles in the tank. I have grown a little this year, and now have an employee one day a week, and I use the weedeater on that day, so it has around 50 lawns on it.

Any ideas on whats going on?

ed2hess
07-14-2006, 07:07 PM
Get all the old gas out of the units and put in new gas.. I assume you have spark arrestor out on these units? Then post again and maybe I can help you further on the Echo. The next thing I would do is put in a new fuel filter, fuel lines(all three) with new breather. May be getting air....on bubbles or may be water?

wmsland
07-14-2006, 09:28 PM
Try taking the muffler off and cleaning the exhaust port. Over time it wiill build up with carbon and clog the port. Also you can try cleaning the spark arrester screen that also gets clogged up and when these both get cloged up it will really effect the trimmers power.

sweatyclippingcoveredguy
07-14-2006, 09:33 PM
Try taking the muffler off and cleaning the exhaust port. Over time it wiill build up with carbon and clog the port. Also you can try cleaning the spark arrester screen that also gets clogged up and when these both get cloged up it will really effect the trimmers power.


Correct sir. I wonder how many people throw their wacker away thinking it is carb problems because they don't clean the muffler cover and screen.

LushGreenLawn
07-14-2006, 10:02 PM
When the problem started I pulled out the screen and cleaned the muffler, although surprisingly after 7 years there was not much soot or buildup at all. The gas is fresh, I run about 3 tanks a day, and I have run it for a few days even with the problem.

I'm new at working on the small engines, when you say breather, are you talking about the air filter? I ran it with that out and it ran ok, I have also changes the fuel filter and put in a new spark plug.

I didn't replace the hoses but I will try that if it may help.

sweatyclippingcoveredguy
07-14-2006, 10:32 PM
Don't know what to tell you then. The little engine is probably just worn out. Things only last so long, and 7 years is a hell of a long time for a trimmer being professionally used to last. Time to retire the thing.

ed2hess
07-14-2006, 11:16 PM
Go ahead and put a carb kit in the Echo they are cheap and easy to install, making sure you pull the jet and clean it out. It is all easy stuff. The jet can be popped out with small screw driver, It is made out of brass.

lawnspecialties
07-15-2006, 05:00 PM
Check the simple stuff first. A couple of times I've had a similar problem and it was a leaky fuel line. Fuel filter, air filter, plug, remove spark arrestor, and check the hose lines. Then, get more serious if it ain't better.:)