PDA

View Full Version : Ferris IS3000 (non inde front) and Peco 12 Vac question


shaltac
07-21-2006, 10:26 PM
I recently purchased a used Ferris IS3000 (older non independent front) and a Peco 12 vac system ($4500 for both). I have a couple of questions that aren't being answered by the manuals I've downloaded, or the searches here.

1) There are blocks bolted to the Front pivot frame (P/N 5044908B if you look at the diagram). These wedge between the pivot frame and the main frame (P/N 5046373B). These blocks prevent the front frame from moving so there is no front "suspension action". The previous owner stated that he unbolts them when adding the weight bar for the Peco. Should I leave these on? should I be running them with the Peco? Is this a "fix" for some issue with the swing type (unsprung) front suspension? I can Email or post pictures if needed to clarify.

2) I've already purchased the Fram equivalent for the (expensive) Kawasaki oil filter. Seeing how the Hydro system in reality runs on engine oil (fancy, expensive, but still just engine oil) I have to wonder if the filter for the tranny is a standard filter too. Looks almost like a 30001 (standard Ford truck filter). Has anyone managed to cross reference this filter to a standard engine filter?

3) Has anyone replaced the fluid in the hydro system (currently black and that = not good). I'm interested in tips on how to best approach this / bleed the system when done.

Thanks in advanced. I'm just a little ole homeowner with 7 acres of varied terrain to mow.

Rusty

shaltac
07-22-2006, 09:06 PM
1) Blocks = Ferris P/N 46797 U-Bracket - removed it
2) Supported the local dealer and bought the Ferris part
3) Done no big deal

Thanks everyone :clapping:

lawnmaniac883
07-22-2006, 11:11 PM
Ok, well to change the hydro fluid you need to remove the filter and let all fluid drain. Prefill new filter and install. Fill hydraulic resevoir until it reads full on dipstick. Jack mower up so that both rear wheels are off of the ground, do not place jack on a pulley or other moving part. Start motor, bring to full speed and work the levers back and forth about 5 times, holding forward and reverse for a few seconds each. Shutdown engine, recheck fluid level in resevoir refill if necessary. Although jacking up the mower is not absolutely necesary I recommend doing it because it will bleed any and all air out of the pumps/wheel motors. I am not positive but I believe you need to use Mobil 1 full synthetic 15w40 in your hydros. Good luck.

shaltac
07-23-2006, 09:58 AM
Yup that's what I did (changing the fluid)
Thanks