PDA

View Full Version : MINI-Z, help with clipping dispersal??


FIRESCOOBY
09-20-2006, 08:23 PM
2005 MINI-Z, 19hp KAW/52".

There's two things I'm not happy with in my MINI-Z. First is the motor size, but that was all my fault.

Second: Clippings. It really doesn't matter if the grass is wet or dry, although it is worse when wet. The deck REALLY clumps up badly to the rear of the discharge opening. I noticed today that more than half was clumped up. What this causes is it is constantly clumping and then slinging large clumps out. The clippings/clumps only go one mower width over. This causes it to look really bad. This is dry, wet, Bermuda, Fescue. I'm using regular blades, Fusions, high lifts...nothing makes a difference.

It seems that if the deck opening was wider it would work much better. I'd be more apt to do some "mods" but I know this would void the excellent deck warranty that I have. I also have a Qwikchute and would have to box the opening out some to make the chute work like it is designed.

PJ or ANYONE have any ideas?

mowerconsultant
09-21-2006, 03:55 PM
What is your serial #?

FIRESCOOBY
09-21-2006, 04:46 PM
I'll get it tomorrow, I'm at the fire station today.

FIRESCOOBY
09-22-2006, 04:57 PM
Sent you an email, but here it is also.

Model# 927236
Serial# 05010136

mowerconsultant
09-24-2006, 01:19 PM
Ok, by looking at your serial # you have the wider discharge opening, I just wanted to make sure.
I am here in Kansas and will bring this to our service managers attention and have him get with your dealer to see what they can find out.

Pj

mulligant
09-27-2006, 09:01 PM
I have the exact same mower except an 06 model and I have the same problems too. I don't think that the 19hp is enough, but I bought it because it was the best deal at the time. Also, I usually end up mowing twice to distribute the clippings or clumps of grass that are left behind. I know that Hustler has excellent quality, but could this problem be somewhere in the design of the mower?

mowerconsultant
09-28-2006, 10:45 AM
Sent you an email, but here it is also.

Model# 927236
Serial# 05010136

I talked to James yesterday about this, he is going to get it looked into when he gets back in the shop.

Pj

mowerconsultant
09-28-2006, 10:49 AM
I have the exact same mower except an 06 model and I have the same problems too. I don't think that the 19hp is enough, but I bought it because it was the best deal at the time. Also, I usually end up mowing twice to distribute the clippings or clumps of grass that are left behind. I know that Hustler has excellent quality, but could this problem be somewhere in the design of the mower?

Has your dealer looked at it?
Have you checked the basics? belt tension? engine RPM's? deck pitch? blade's?
How many hours are on this unit?
We can get this taken care of I am sure.

Pj

mulligant
09-28-2006, 04:06 PM
My mower has about 90 hours on it and I haven't had it back to the dealer since it was purchased 5 months ago. My deck belt tension is fine to my knowledge and hand test, engine rps sound the same as when new, the blades are sharpened periodically and that doesn't make a difference, and I have not checked my deck pitch.

Thank you,

Tyler

tn mac
09-30-2006, 09:57 PM
Get some gator blades, that will make a big difference,the fusion blades just don't cut the grass into small enough pieces. for the fast growing southern turf.

mowerconsultant
10-01-2006, 06:08 PM
My mower has about 90 hours on it and I haven't had it back to the dealer since it was purchased 5 months ago. My deck belt tension is fine to my knowledge and hand test, engine rps sound the same as when new, the blades are sharpened periodically and that doesn't make a difference, and I have not checked my deck pitch.

Thank you,

Tyler

You need to get this unit to your dealer and get them involved.
E-mail me your info and your dealer's information and I can get the regional service manager involved also.