PDA

View Full Version : What happened to the "anybody cut with a triton" thread?


ProStreetCamaro
10-31-2006, 04:15 PM
Did it get deleted? Did exmark ever fix the problem? I havent been around in a while and am just curious what ever happened to all the guys that had horrible cutting Triton decks? I couldnt find the thread so I assume it got deleted.

dave k
10-31-2006, 04:38 PM
From what I read they have been fixed and they will do a fix on any decks that need the kit free of charge, thats what they say on the Exmark forumn. Good for Exmark!

Daner
10-31-2006, 05:07 PM
The next thread will be...Has any one mowed with the new 2007 Triton deck

tacoma200
10-31-2006, 06:33 PM
Yea the Exmark guys at the Expo showed me in detail the problems. These deck worked great in Florida but they did have area's of Northern grasses where it didn't do as well. The left chamber had so much lift that it was lifting grass up and creating a vortex where it was never passed to the center chamber. It just kept circling. they put a small optional piece in the left chamer to force it to send the grass over to the center. Also another problem between the center and discharge chamber was it was directing some grass to the rear of the discharge causing a build up. This is being addressed by a straiter front baffle on the new decks so that the dicharge is not directed as much toward the rear turbo baffle and flows out the discharge much better. Of course it will be next Spring before we can get a clear picture of how this will play out.