PDA

View Full Version : 17hp Kawasaki Throttle Cable


CandJ
06-22-2001, 09:45 PM
I have a 52" Scag with the above engine. Over the last 4 - 5 weeks I have gone through 2 throttle cables. The problem is this - the cable gets hot and the outer covering melts, this freezes the cable in whatever position it was last left in (so I need to remember to leave it in full throttle to restart after it cools). After running the mower for a few minutes, the cable moves just fine. I put another cable on the unit last week, and had the same result by the end of that mowing day. I looked thru the manual to see if a heat shield or something came off, but no. Just wanted to get some input and see if this may be a problem inherent with this engine before I replace another cable.

FYI - I have owned this mower for 1 1/2 years before encountering this problem.

Thanx for any input.

Jim

Jason Pallas
06-22-2001, 09:56 PM
I'm pretty sure the 17hp the 15hp Kaws are about the same. I had this very problem with our 15hp on a 48 Lesco. The outer plastic sheild melts away because of the way they've routed the throttle cable under the red-hot exhaust. However, ours didn't freeze up like yours. I simply re-adjusted the cable position and it has done fine _ however bad planning on Kaws part to mount the exhaust / carb in such close proximity. In addition, the carb mounted on the front on the unit exposes it to all sorts of debris ( going through air filters like crazy!!) The 14hp is a much better designed engine. Good Luck