View Full Version : Anyone ever pull a hub off an Exmark WB?

02-06-2007, 10:37 AM
I have a 60" Exmark Turf Tracer WB that needs the drive motor re-sealed.

I can't for the life of me seem to pull the hub off the tapered shaft??

Heat maybe?

02-06-2007, 02:35 PM
No Heat Do You Have The Motor Off The Machine?

02-06-2007, 02:42 PM
They can be next to impossible to get off. I had to get one of a ferris dual drive before and I fought and fought. I had to use heat to get it off. Just be smart when you use the heat. I used oxy/acc and actually cut part of the hub. Just be careful not to cut the shaft. I cut releases going from the center of the hub where the lugs are out to the edge but not all the way or you can't get on it with a puller. Then you can heat the part of the hub that slides over the shaft. With the releases cut, it will help let the hub expand. I then used a heavy duty 3 jar puller with an impact wrench while heating it. This was one of the most difficult repairs I've had to do to a mower. Be careful b/c you can damage the shaft or motor. Good Luck.

02-06-2007, 05:56 PM
No heating or cutting, get a hub puller like this one

Jason Pallas
02-06-2007, 06:39 PM
I need to get one of those!!!

02-06-2007, 07:38 PM
that might have helped me but my mower was about 5 years old and it was completely seized on. Let us know if you get the one off your exmark and how you did it.

02-08-2007, 12:23 PM
Ok.. I found success!

A little heat from a map gas torch that I used for a plumbing project, a 3 arm puller from Autozone, and an impact. I was thinking it would slide or give some indication of coming off. It pretty much popped off with a loud bang and hit the floor.

Now the motor is at the dealer getting a new seal kit installed.

02-08-2007, 05:10 PM
just make sure the hub is not bent from the puller before you put it back on.

02-08-2007, 08:21 PM
just make sure the hub is not bent from the puller before you put it back on.

That is the reason I prefer the hub puller, Alot easier to reinstall your hub when its not egg shaped:laugh:

02-08-2007, 08:41 PM
I agree but I wasn't able to find that type of hub puller local.

02-09-2007, 04:44 AM
Remember when pulling, you just don't keep cranking the puller. Like stated, you can screw it up. Spray it with GOOD penetrating oil. Put tention on it and whack it with a hammer.