PDA

View Full Version : Help Needed!!!!!!!


zimbobthelandscaper
02-17-2007, 02:03 PM
ok we are having problems with our 94 chevy k2500 with the back up light every time the truck is put in to reverse a fuse is blown and the backup lights and directionals dont work change the fuse same thing happens we just disconected the backup alarm that dosent work anymore and it didnt help at all anyone have any ideas as what is causing this??? thanks alot for any info!!!

teamoneoutdoors
02-17-2007, 02:17 PM
You have a short in your backup lights. Make sure there is not a wire that is exposed. Be patient and don't get frustrated. You will find it.

zimbobthelandscaper
02-17-2007, 02:24 PM
thanks thats what we are going to check next thanks alot!!!!! but if anyone has anything other than that let me know just in case thats not it lol :waving:

teamoneoutdoors
02-17-2007, 03:02 PM
Try going and removing any wiring for the back up alarm. If the alarm was not wired from the factory someone ran a hot wire to the fuse block. Remove that hot wire from the block.

FIXDISS
02-19-2007, 05:34 PM
Try removing both bulbs from backup lights and put it in reverse. If fuse does not blow then replace one bulb at a time . Could be a bad base on bulb or a shorted bulb socket. Any water in the assembly ?

bigmudder77
02-20-2007, 11:22 AM
if you cant find out whats wrong go and hard wire it. my guess is a short in the wire some place if you cant find it and are tried of looking just cut the wires and wire it up your self. its not the best thing to do but it works. or just go with out lights and alarm who needs them

topsites
02-22-2007, 06:57 PM
Have you tried the Chevrolet version of Lawnsite?
http://www.chevroletforum.com/