PDA

View Full Version : Zama carb rebuild how to....


Hardwareman
03-27-2007, 12:04 AM
Has anyone rebuilt one of these carbs before?

I'm going to go buy the rebuild kit at my local "Lawn Mower" shop in the morning and any help would be greatly appreciated.

The model # of my Zama is: C1U-H39

Thanks for the knowledge y'all!




Allen

LCPullman
03-27-2007, 01:20 AM
One of the most important factors in a successful diaphragm carburetor rebuild is cleanliness. Any dirt, or a dusty situation can ruin your carb rebuild. Use a very clean work area, clean tools, clean cloths. Before you disassemble the carb clean the outside really well. When you have it open, use compressed air to clean the passage ways.

Hardwareman
03-27-2007, 01:19 PM
Thanks for the help. I just called to see if the shop has the parts I need. They took my number and said they had to call me back. Hopefully this will resolve my issue. I'll post back up later after the works been done.




Allen

Hardwareman
03-27-2007, 09:51 PM
All righty then!

All seems well here in sunny SoCal! I hope I'm not speaking too soon here but I've rebuilt the carb the best I know how and it seems to be fine now.

I actually waited for a while to make sure and it still seems good. It even runs at full throttle in position #4 unlike before. I may need to tweak the little red screw some but that's about it. I replaced the needle spring deal that's actuated by a rotating shaft under the diaphram also. The only thing I did'nt remove/replace were the parts inside the red adjustment screw because I could'nt figure out how to get it off. I don't even know if anything in there needs replacing...lol.




Allen

LCPullman
03-28-2007, 12:12 AM
Glad things went well.

Hardwareman
03-28-2007, 01:26 AM
Sorry again. Still having issues here.




Allen

LCPullman
03-28-2007, 01:34 AM
What problems are you having? What machine are you dealing with?
Have you checked/replaced fuel filter?

Hardwareman
03-28-2007, 02:29 AM
It's a Homelite with the C1U series Zama carb. It bogs down when accelerating to the point of stalling when in position 4 which is supposed to be the normal running position. It idles fine however.

As for a fuel filter, it does not have one (I did'nt get it with one either) unless it's in the carb and I did'nt see it. Is it supposed to be in the tank connected to the inlet line?

Also, when I installed the carb kit I may have put the diaphram on before the gasket and the illustration in the service manual shows the gaskert first and then the diaphram. Could this cause it?



Allen

LCPullman
03-28-2007, 02:43 AM
A reversed gasket/diaphragm definately could be a problem.

Just about all of my equipment has some sort of fuel filter at the tank, connected to the inlet line. Does your service manual say anything about a fuel filter? If you had a fuel filter, they could get clogged. If you don't, stuff in the gas can get into the carb.

Another thing to check is the condition of the fuel line. If it weathered and cracked, you could be sucking in air with the gas, thus not getting enough gas.

Something else to check is whether you have a spark arrestor screen (at the muffler opening.) Alot of newer 2-stroke stuff does. When this gets clogged, the engine won't rev up. It could be something that screws into the muffler opening or it could be under a plate at the muffler opening.

LCPullman
03-28-2007, 02:51 AM
Regarding the fuel filter, if you got it new and it didn't have a filter at the tank, you probably shouldn't worry about it unless you see evidence of dirt in the carb.

Hardwareman
03-28-2007, 03:36 AM
Yep it does have a spark arrestor and it's not clogged. The fuel lines are new as well and not leaking at all. I think I will reverse the diaphragm tomorrow and see if that helps it. I still plan on using it tomorrow as it only appears to be a problem in one of the positions as of now.

I really appreciate the advice and "where to look" info Pullman. Thanks.





Allen

ose58
04-02-2007, 02:30 AM
If It Bogs When You Squeeze The Trigger Richen The Slow Speed Mixture Screw A Quarter Turn To The Left As You Go This Shoud Eliminate This Problem.it May Take A Few Times. You Then Will Probably Have To Adjust The Idle Speed Screw As Richening The Mixture Will Tend To Slow The Idle Speed.