PDA

View Full Version : Toro ZMaster Hydro losing prime?


Countrybois
04-09-2007, 07:24 AM
I just bought a used (1135hrs) Toro Zmaster Model 74245 '94 model. Upon startup, the right hydro doesn't do a thing. After about 2 minutes of running the left side front and back eventually the left side starts to whine and then seems to work fine. I went out and mowed with it and the left side seemed sporadic(sp). It would work fine, and then lose 'power'. It seems to me like it is not keeping it's prime. But then again, I don't know this system. When I picked it up from the dealer, it was a little noisy and he said once it warms up it would be fine(like 3 minutes). Granted it was about 20 degrees outside, so I bought it, after all I assume hydro oil can thicken in cold weather the same as any other. The dealer did give me a 90 day warranty, but he is also 2 hours away, so if it is something I can fix, I would just assume do that.

I searched throughout this site and can't find this problem. I'm hoping that is a good thing and I am just an idiot in this area. (Which is very likely)

khouse
04-09-2007, 04:19 PM
Try changing out the hydro filter and check the level of the fluid.

razor1
04-09-2007, 04:32 PM
In my experience, cold weather doesn't effect hydros that much.

That's not many hours for a 13 yr. old tractor. Was it used commercially?

You can call Toro with the serial # to see if they have any records on the machine. They also have a help/tech line.
Good Luck

mini14
04-09-2007, 08:46 PM
look underneath and make sure hydro drive belt is nice and tight, the idler has a grease fitting that many people overlook...if the tension isnt tight on that belt u will have probs. make sure your dump valves are nice and tight also.

khouse
04-09-2007, 09:26 PM
Good idea mini14.

Countrybois
04-10-2007, 06:17 AM
It's an '04 not a '94. I think I found it. Two of the hoses going to the pump on that side had no clamps on them, so it was probably sucking air. I will update after I get a chance to run it a while. Thanks for the input!