PDA

View Full Version : Walker Transmission Service


dwc
04-18-2007, 11:31 PM
Just wondering if anyone could tell me the easiest way to change the hydo fluid in a Walker? The final drives were easy but there is a lot of stuff in the way to drain the hydros. This looks like a dealer job to me unless someone has an easy way.

lucforce
04-19-2007, 08:29 PM
Remove the deck, put drain pan under pump, and remove drain plug. Remove and clean the plastic cups and caps with soapy water and let dry. Reinstall removed parts and refill through the large plugs on the top of the pumps. Top off the fluid in the cups. Run and check fluid level after warm.

dwc
04-19-2007, 09:24 PM
Sounds simple but how do you get to the right trans drain plug with the linkage in the way?

pclawncare
04-19-2007, 09:32 PM
I just did this my self this winter it wasnt too bad of a job i believe but dont quote me on this but i think i used an open end wrench to get to that i know i remember it being a pita. Also another thing to watch out for when you remove the cups there is a nut shape molded into the in side that you cant see very easy because all oil wont drain out around it but you can guess the socket size i dont remember but put it down in there and make sure it fits also it is not standard thread its backwards righty loosy lefty tighty dont want to go the wrong way its just plastic and ya it not too bad i think it took me an hour to do gear boxes and hydros most of the was drain time.

slowpoe
04-19-2007, 11:53 PM
:cool2: You do not want to get any contaminants (dust,grit,dirt what ever) in the oil or hydro unit. Best bet is to wash down the mower & clean around the plastic resivor lid & at the bottom were it screws in to the hydro unit really good.
:confused: Also never unscrew the lid to check the oil when the mower is dirty & it really should be left on & checked through the plastic

:hammerhead: I went though three hydros, I think because of these reasons & also if one of them is going out ,get it changed before it wears the other side out. The good side takes all the stress:cry: A $1500 dollar lesson

Just for refferance I have a 1999 26hp EFI with 3125 hrs. on it ,origonal motor still going strong:waving:

PS Always keep an eye on the hydro fans also:usflag:
And of corse keep the unit clean of debri with the blower:nono:

pclawncare
04-20-2007, 12:59 AM
How exactly can you tell when one of the hydros is going out? my older walker a 99 with 1800 hours on it has been acting up a little lately well for a little while and i cant figure out what the deal is. It drives straight and everything but sometimes i will be going a long and it almost cuts out making it go to one side then it will kick back in and go straight in a new direction not too bad of a thing but if i wasnt paying attention could be bad just wondering what could be wrong?

lucforce
04-20-2007, 07:22 PM
pclawn,

I believe that you have a wheel gearbox binding.

lucforce
04-20-2007, 07:25 PM
I am assuming, of coarse, that you havr checked he belts, pulleys, and tensioner springs.

pclawncare
04-20-2007, 08:10 PM
yes to the belts and tensioners springs it only happens every once in a while and seems to happen on concreat i dont know why but i dont seem to notice it when im mowing. I do know i have a gear box leak but its on the oposite side from the side thats acting up i just check it regularly and refil if its not at the top

slowpoe
04-21-2007, 12:51 PM
It does sound like you may have a gear box issue. I would drain the gear box oil & check it (the oil) for metal chunks if you have not done so in a while.Or the belt could be loosing contact w/the pulley.Check the tensioner pulleys for bearing play or binding.

As for knowing when the hydros are going , you should be able to tell when the unit is hot and one side is not pulling as hard as the other side and mower is not tracking straight and is more noticeable when mowing on hills. when this happens the good hydro is doing all the work & over heat which then damages & wears it out

The 2 leading causes of hydro failure are heat & contamination
:nono:

pclawncare
04-21-2007, 03:45 PM
I just drained the oil this winter on the gear boxes and nothing came outwith them except for a few little shavings on the magnet on the top but nothing out of normail

ed2hess
04-21-2007, 05:11 PM
PClawn....make sure all those spring in the steering linkage are cleaned up and lubed real good. If they stick you can get impression that drive fails.

slowpoe
04-22-2007, 12:14 AM
Stuff on the gear box magnet is normal as long as there were no big chunks,so they are probably fine.

Maybe the emergency brake is sticking:confused:

Maybe air bubble in the hydro from last oil change (if that is even possible)

I never had that kind of issue so I am stumped:dizzy: