PDA

View Full Version : Elec. hedge trimmer problem


dfor
08-03-2001, 05:04 PM
I have a set of Little Wonder electric hedge trimmers that quit working today while trimming. I could hear them slowly starting to lose power. Then just quit. Anybody know what might be the problem? I'd just like to get a heads up before bringing them in to be fixed. Maybe I'll be able to do it myself with help from you people. Thanks.

thelawnguy
08-03-2001, 05:11 PM
Check the brushes? Two large screws on either side of the motor.

75
08-03-2001, 05:58 PM
Were they "gradually losing power" over a long period of time, or just during the round of use when they died?

Either way, checking the brushes as Bill suggests should be easy to do yourself. Relacing them should be a simple job if that turns out to be the problem.

Only snag you might run into is where to order replacement ones - not sure what you have in your area for power tool/electric motor repair places.

Grapevine
08-03-2001, 08:32 PM
It's probably the brushes like these guys say, but also check the cord. A lot of times with all the pulling and twisting the connection can come loose in the handle. I like the Echo hedge trimmers because they're lighter than the gas and cut well, but I usually go through them about every 2 years and buy another set. I have 2 small Mantis pruners, 1 Echo, 1 Little wonder (all electric) I finally bought 2 Stihl gas hedgers because I was tired of my guys constantly cutting through the cords.

dfor
08-05-2001, 07:35 AM
I only noticed loss of power on the day they quit, but it may have been longer. In any event, $6 and a new set of brushes, they are back up and running. Thanks for the help.