PDA

View Full Version : Kohler CV12.5S blowing fuses


Greg Hackbarth
04-24-2007, 04:38 PM
I have a Cub 1320 mower with a Kohler CV12.5S engine. When I turn the key to the run position, the fuse blows. If I replace the fuse and turn the key all the way to the start position, the mower will crank and fire and continue to run when the key drops back to the run position... though the fuse blows again.

I have eliminated all of the safety switches, lights, etc from the equation, leaving only the alternator, rectifer/regulator, starter, solenoid, ignition switch, coil/magneto, fuse, and battery. Since the fuse doesn't blow in the start position I can assume the problem is in the two circuits that are connected when the key is in the run position... and the B side of the ignition switch is common to both positions, so I assume the problem is in the alternator and/or rectifier.

Just wondered if you guys tend to agree, and also ask if there are ways to test the alternator and recifier/regulator for shorts to see which needs to be replaced?

Restrorob
04-24-2007, 08:37 PM
A quick test for the Stator (alternator) is leave the regulator un-plugged and try another fuse.

Or un-plugging the regulator and put the pos. lead of your multimeter on one of the white wires then the neg. to ground (ohms setting of course) then test the other white wire. You should have a open circuit if not the stator is shorted to ground.

There is no multimeter test for the regulator I know of, If it shorted to ground it would most likely take out the stator.

If the stator test OK, Check the ignition switch for a internal short. With the switch un-plugged put the pos. test lead on the run position post (with the key on) and the neg. to a ground, It should be a open circuit if not the switch is shorted. If the switch test is OK looks like you will need to start tracing wires for bare spots shorting to ground.

You can take the starter and solenoid off your list because they only get power in the start position.
You can take the coil (Module) off because if battery voltage is introduced to it "POP" it will blow.

Greg Hackbarth
04-24-2007, 10:24 PM
Thank you, stator was shorted out so I took off the flywheel and found out that several magnets had come off the inside of the flywheel and smashed up and bent the stator badly. There were peices of magnet everywhere. Unreal. Ordered a flywheel, stator, and rectifier for good measure from Ebay just now.

Restrorob
04-24-2007, 10:39 PM
Glad to hear you found the problem, Electrical shorts can be relentless sometimes.....

khouse
04-24-2007, 11:37 PM
I think they need to come up with some better glue for the magnets! Maybe a finger groove or something - some kind of mechanical fastener.

Restrorob
04-24-2007, 11:49 PM
some kind of mechanical fastener.

That would be the ticket khouse,
What I have noticed is moisture gets between the magnet and flywheel then as the rust forms between the two it pops the magnet loose.