PDA

View Full Version : Kohler CV 20 ignition problem


Jason Pallas
04-27-2007, 10:46 PM
My left side igintion on my Kohler CV 20 just stopped. No Spark. Plug is good but no iginition on that side. I'm going to replace the ignition module on that side - but thought I would ask you guys if there is anything else that I should check as well. Thanks in advance - raining like crazy for the last few days, grass is growing like mad and I really need this machine (with 2 working cylinders!).

Jason Pallas
04-29-2007, 01:17 AM
anyone? Rob? God? Santa? anybody at all?

MowerMedic77
04-29-2007, 07:34 AM
raining like crazy for the last few days,

Any chance you just have moisture in the plug boot? How are you testing for spark? I have seen intake gaskets leak and give a lean run on a cylinder and it acts exactly like a no spark issue. What is the compression on the cylinder? May have a rocker arm off.

Restrorob
04-29-2007, 09:27 AM
How are you testing for spark? .


Good question MM,

If checking properly and no spark and your engine is equipped with a SAM (Spark Advance Module) check the spade connectors and coil mounting screws for corrosion then check spark again. If still no spark you can test the coil per the chart below. If the coil checks within specs the problem is most likely within the SAM it's self.

If your engine is not equipped with the SAM then disconnect the kill lead from the coil in question and check for spark, If still no spark replace the coil.

The part number will be stamped in white on your coil to find the proper test specs in the chart.


http://i107.photobucket.com/albums/m314/Restrorob/CVCoilTest.jpg

Jason Pallas
04-29-2007, 09:25 PM
Thanks guys - replaced the module and it took care of the problem - but yo guys gave me some great info for the next time. Rob, if the SAM was bad, would that affect only one cylinder / spark or both ? Just curious. Thanks again guys!

Restrorob
04-29-2007, 09:48 PM
It can effect one or both, The SAM controls when the coils are to fire.
I had a instance where I was hit with a stump grinder one weekend running on one cylinder. My multimeter was at work so I swapped the coils and the good one had no spark on the other side either, Needless to say the SAM was at fault.