PDA

View Full Version : Transmission help needed ASAP


Mark13
05-25-2007, 08:27 PM
About an hr ago while I was mowing the mower stopped moving mid pass. The mower is a JD L120 lawn tractor with the hydro transmission. I was moving along and all of a sudden I heard what sounded like pressure being released and then it stopped moving. Neither of the forward or backward pedals have any force against them (very easy to push down), the clutch is hard to push in, and the mower will roll easily while in "drive" mode. The hydro transmission in our last mower went out, but it made a grinding sound and would move forward still but at about .5 mph. Any tips or information about what could be wrong with it would be greatly appreciated.

Restrorob
05-25-2007, 08:51 PM
I'm not familiar with the Deer line but with the full model and serial numbers I may be able to look it up and shoot you some things to check.

fireman649
05-25-2007, 09:00 PM
Check all belts and the spring to the pulley that controls the clutch. It sounds as if something may be jammed, or the belt broke. Check underneath and then let us know

Steve

Mark13
05-25-2007, 09:05 PM
I looked underneath as soon as it happened and I seen no broken belts or leaking fluid. When I would push on the foot pedals for the hydro, the pedals, connecting link, and arm that went into the transmisson would move but the mower would not move.


As for the serial numbers, I will have to go look for them.

EDIT: Transmission- Tuff Torq - 7A646024390 S/N-46ACO237026
I also found a loose belt way up underneath, I assume it goes to the transmission. I just have to find out where the pully on the transmission is (transmission is 95% hidden under body work, fuel tank, tires, and hitch assembly)

Mark13
05-25-2007, 10:03 PM
After taking the deck off I was able to find where the belt went. Tomarrow I will get a new belt so this one which I am sure is stretched after 360+hrs will not keep comming off. Thanks to all those who offered a bit of help.