PDA

View Full Version : Mulch Kit Problem Snapper 30 " RE200 (Simplicity Coronet)


re200
05-26-2007, 07:12 PM
Ordered new compact Snapper RE200 30 inch single blade rear engine hydrostat aka Simplicity Coronet rear engine rider with the sole intention of mulching grass. Dealer ordered mulch kit and "installed" it, cover and blade. I needed a compact unit. Take orientation ride at dealer. Engage mower deck and smoke comes out underneath deck. Blade is jammed against mulch cover and the belt is straining against the stuck blade pulley creating the smoke. Why the mechanic didnt figure this out when he put the blade on is beyond me. Just one rotation would have found this out. Put on lift at dealer and it is obvious the mulch cover is poorly designed. There is almost a one inch gap between the top of the cover and deck which allows grass to escape. The cover had to be forced into a more rounded shape by use of a clamp to gain some more room for the blade to clear. Even after this the mulch blade is still banging against the cover. Now the dealer says that these decks were not really good mulching decks anyway after I originally bought the unit based on my telling him it was only for mulching, no bagging no grass to be picked up. So my question is does anyone have any experience with a mulch kit on a Simplicity Coronet 30 inch single blade mower aka Snapper RE200?

Chop Stuff Up
05-28-2007, 05:57 AM
I believe they have something called a "ninja" blade setup for that mower. I think its used with an open chute tho.