PDA

View Full Version : replaced ignition switch plug and may have shorted something out


Ronlawn
05-29-2007, 06:58 PM
I got the parts today to replace the deteriorated ignition switch plug I was asking about last night here. I replaced them one at a time as I took them off the old plug. Except for the first 2 that were already loose. I got them switched, the L with the S, and when I tried it it wanted to start in the run rather than over in the start position. Sorry to say I didn't take the cable off the battery while working on this.

Not knowing yet what was wrong and starting to lose composure I looked at the schematics again, got confused between right side up and upside down, and between plug and switch and thought I had the sides switched and that 3 wires were somehow in the wrong place. luckly or unluckily the connectors were not staying stuck in the plug so I pulled them on through and started sliding them individually on to the switch post I mistakenly now thought were the right ones. While I was putting the the final wire, the yellow start wire on the ground part of the switch, and holding it with needle nose plyers I kept bumping the other posts and it was making the starter try and kick. But I finally I got it on and then some clicking sound started coming from the other side of the engine (Briggs Vanguard 15.5) where the starter(but it wasn't a regular starter sound) and the regulator and who knows what ease is. Then I started yanking the stuff off the starter switch and wondering what I'd done.

It was then that I realized I had the L and S switched. So I put those right and tried to start the mower. This time the starter engaged in the start position but the unit won't fire, the starter cranks and cranks but the engine won't take.

Restrorob
05-29-2007, 07:24 PM
OOPS, Sounds like you may have fed battery voltage to the ground lead on the coil and blew it. Disconnect the black kill lead wire down by the engine and check for spark again, If still none replace the coil.

Ronlawn
05-30-2007, 08:36 AM
Yes, OOPS is right. I just appreciate your reply diagnosing what likely got damaged, I didn't have a clue yet. You've probably saved me from the extra money and time loss of taking it to the shop due to my mistake.