PDA

View Full Version : Help craftsman hydrostatic deck issue


cowboyfan723
06-04-2007, 06:12 PM
Hello I have a craftsman hydrostatic lawn tractor When I try to engage the deck I get sparks under the engine and if I let it go long enough it will kill the engine. But if I push the deck button off it runs again Its like the pully is binding up. I have only used this mower twice, any info would help.
Thanks

Jay Ray
06-04-2007, 09:06 PM
The first thing I would do is check to see that the bolt that holds the stack pulley to the crankshaft is tight and the key (the stamped bumps on the bore of the stack pulley) is not sheared off, but that is just the first thing that popped into my mind. On some older riders you had to drop the front of the deck to access the bolt. I don't know about yours.

I never had your particular situation, but remember having to lower the stack pulley part ways off the crankshaft in order to to change drive belts.

Also, post your question in the Mechanics and Repair forum because there are some sharp and experienced guys there that have probably seen this before. They are probably going to ask you for model numbers on the tractor and model and spec numbers on the engine, so get the numbers and put them in your first post.

Hope you get it resolved easily and quickly.

SOMM
06-05-2007, 10:27 PM
dag!!!!!

why don't you just take it back and get a new one?


Tells us all if that works, ok?

ke5hbd
06-09-2007, 02:34 PM
Take the blade off the deck and see if the blade spendals are free and not locked up.

Check the pully on the engine crank also.