PDA

View Full Version : Ignition problem on old points-based Kohler


topsites
06-12-2007, 11:09 AM
I have an old troy bilt tiller with the K161T 7hp Kohler, and it won't start.
Best I can figure, after spark testing, is no spark...
Yes, the fuel is atomizing dandy, I put a new plug in it, with the air filter off it's obviously getting air.

I did order a kit, but I have little knowledge on points systems, is it usually the condenser or what?

thecrankshaft
06-12-2007, 02:22 PM
A faulty condenser will wear out points, but usually not prevent the engine from starting. The "T" designates retractable start so this engine will most likely have a magneto ignition.

If you bought a kit, good idea, otherwise clean and gap the points to .020", make sure the ground is good on the case of the condenser and take some resistance checks of the coil.

Bill Kapaun
06-12-2007, 03:24 PM
IF you remove the condenser, the engine should at least "pop", if it is faulty.
Condensers CAN "short", which results in no spark.
The purpose of the condenser is to "absorb" the electrical "arc" when the points open, preventing transfer of metal from one contact to the other. The "arc" also tends to "drain" the stored electrical charge in the coil, reducing the spark "intensity" to the plug.

heritage
06-13-2007, 12:17 PM
Points could be bad and also if coil/condenser/points/air gap are o.k. , Then replace the flywheel key with a new one from kohler. Be sure to clean the surface areas, and spray with a contact cleaner to remove any oils.

These engines last forever, when running :)

Pete D.

topsites
06-13-2007, 07:25 PM
Well I had pulled apart the front of it, where the magnetos are housed, and blew all that out real good with some compressed air, but no... So then I ordered the kit, I think $30 with shipping.

Replaced those parts when they came in, I was really dreading that stupid gap, I've dealt with this before on a 1974 Ford and all I remember is spending the better part of an afternoon just on that. But I got lucky this time (first try lol), now it runs great. Does pop and sputter and surge a little but I can deal with that, I'm sure it's 20-30 years old, I changed the oil as well.