PDA

View Full Version : need help.


timmac
06-13-2007, 06:58 PM
I have a hustler super z and today when I started mowing, the mower didn't seem as fast. I kept on mowing though. On my first yard near the end I started smelling a strange smell (hydro oil). when i finished i raised my seat and there was hydro oil everywhere. It seemed like it was coming out where you put the oil in. I didn't mow anymore yards. What do you think is the problem? I have no clue. Taking it to the dealer tomorrow.

KTO Enterprises
06-13-2007, 07:03 PM
Possibly overfilled

timmac
06-13-2007, 07:05 PM
i've been mowing all year and had no problem with it yet. i did get it back from the dealer today for a different issue(not mowing level). they didnt say anything about adding any oil to it.

timmac
06-13-2007, 08:29 PM
anybody else?

fiveoboy01
06-13-2007, 08:31 PM
Uh, probably a leaking hyro hose or fitting...

khouse
06-13-2007, 09:18 PM
Vent plugged?

timmac
06-13-2007, 11:12 PM
Vent plugged?

what does this mean?

khouse
06-14-2007, 12:05 AM
There's got to be a vent in the hydro reservoir tank. Either by itself or in the fill cap. I may let it build up pressure in the tank.

timmac
06-14-2007, 11:17 AM
took it to the dealer this morning and he said the way it looked that the oil cooler vent needed to be cleaned. I just washed my mower last week, could I have stopped it up when I washed it?

khouse
06-14-2007, 11:21 AM
You never know -maybe?

timmac
06-14-2007, 11:06 PM
cleaned the air cooler and it is all fine now. it was just clogged.