PDA

View Full Version : Redmax EB7001 wont start


Ralph Wiggum
07-10-2007, 12:47 PM
I bought this blower used last year and it has been great until this week, I was in the middle of using it when it started to struggle to stay on until it just shut down so i put it away and took it out yesterday, it started on the second pull as it always does but died again after just a few min of work.. now it wont start at all... today i replaced the spark plug and gas filter (the air filter looks ok) not sure what to do next. I would hate to take it in and get banged for a few hundred bucks.... I hear removing the exhaust screen might help but i have no clue how to remove it....

MowerMedic77
07-10-2007, 01:32 PM
Do you have spark after the unit shuts down? Also remove ur recoil and check the seal on the crank I have seen alot of them pushed out on these units in the past. Most times they will not start with the seal pushed but still easy enough to take a look to be sure.

themowerman
07-11-2007, 12:00 PM
Take off the muffler and inspect the piston and cylinder walls.....sounds like it may have given up the ghost.....If there is no scoring then clean the carbon from the muffler and exhaust ports, check your ABCs....are you getting fuel...spark...do you have compression?

Ralph Wiggum
07-13-2007, 12:56 PM
OK so i tested it to see if i had any spark (i didnt) so i went out and picked up a new coil, after i installed it the blower started on the first half of a pull (very cool) but it still wont give me the full power.

So far I have replaced the spark plug, gas filter, coil, and i removed the spark arestor from the muffler.... thanks for all the help guys