PDA

View Full Version : tecumseh compression relief prob


diggerdave65
07-13-2007, 08:46 AM
hi all looking for any thoughts on the below problem:
Tecunseh XL/C 17hp OHV
mod OHV17 204605B (h)
fam STP 490UIG2RA
DOM 7346S
Problem is machine will not turn over more than once. (with plug out the engine will turn over all day long so no prob there) I have spark.
So I suspect the exhaust valve lash if off. Sure enough at TDC I can get .008 feeler guage under the rocker. Supposed to be .004 according to shop manual. I reset it and no dice. Turns over once and cant get past that compression.
Is it possible that the comp relieft on the cam is "stuck" or frozen?
Never dealt with a compression relief that is on the cam before. I believe mine is NOTthe kind that is a small bump on the cam journal. Can anyone shed any light on what I might be up against/ how to fix this. I understand that the comp relief is part of the cam and not a separate part correct??
thanks for any input.

Bill Kapaun
07-13-2007, 02:49 PM
You can get a service manual here-
http://www.cpdonline.com/695244a.pdf
It's a mechanical release ATTACHED to the cam.

IF you haven't yet, do check ALL connections related to the starter motor. Battery ground cable to frame, engine ground to frame etc. besides the + connections.
IF you have a voltmeter, you can check for voltage drop across individual connections. You'd sure hate to tear the engine apart and find out the CR was fine and the problem was a bad connection.

johnp900
07-13-2007, 03:49 PM
Those engine are notorious for breaking the ACR on the cam. That's probably the problem