PDA

View Full Version : tecumseh compression relief prob


diggerdave65
07-13-2007, 07:48 AM
hi all looking for any thoughts on the below problem:
Tecunseh XL/C 17hp OHV
mod OHV17 204605B (h)
fam STP 490UIG2RA
DOM 7346S
Problem is machine will not turn over more than once. (with plug out the engine will turn over all day long so no prob there) I have spark.
So I suspect the exhaust valve lash if off. Sure enough at TDC I can get .008 feeler guage under the rocker. Supposed to be .004 according to shop manual. I reset it and no dice. Turns over once and cant get past that compression.
Is it possible that the comp relieft on the cam is "stuck" or frozen?
Never dealt with a compression relief that is on the cam before. I believe mine is NOTthe kind that is a small bump on the cam lobe. Can anyone shed any light on what I might be up against/ how to fix this. I understand that the comp relief is part of the cam and not a separate part correct??
thanks for any input.

khouse
07-13-2007, 09:27 AM
I think on your engine you'll need to turn it past tdc maybe 1/4 to 1/2 inch to set the valves. But I would make sure the battery and starter are in top shape.

Restrorob
07-13-2007, 12:05 PM
The valves on this engine are set a TDC, Did you check the intake valve clearance ? The compression release operates on the intake valve. With the valve cover off and spark plug out rotating by hand, Can you see the intake rocker bump open a little just before the piston hits TDC ?

You may check the battery/starter and connections as khouse said also.

kcrudy
07-13-2007, 12:58 PM
:usflag: sounds like you may need to replace the cam - as Tecumseh has had problems with some of there cams.