PDA

View Full Version : Power Loss on John deere Sx 95 Kawasaki 12hp


markmisky
07-24-2007, 10:48 PM
I have an old JD SX 95 that I bought a few years ago for small jobs. It is starting to loose power gradually. It runs fine if the mower deck is not
engaged but when you are mowing, it will loose power when I go side
ways accross a hill where I am tiliting to the right or left and also
some times when I turn real fast. It runs OK but not great on level
ground with the mower engaged. It is slowly getting worse over this
summer.
I think it is the carb, but it is a bear to get at so I'd like some
opinions before I have to tear the housing apart to get at. Maybe I
have some dirt or corrossion in the bowl?
I have checked the fuel pump and it is putting out lots of gas, I
also changed the gas filter and also put in new gas lines since the
old one was leaking. Also tried cleaning the carb throat with cleaner.
None of this helped at all
Would appreaciate any ideas.

khouse
07-24-2007, 11:11 PM
Change the plug - it's cheap. But it sounds like either the vent in the fuel cap is plugged or your going to have to clean the carb.

markmisky
07-27-2007, 10:29 PM
Well, I changed the plug, tore the carb apart and cleaned the vents and same problem. This carb has an electrical plunger on the bottom that seems to be some sort of solenoid. Possibly an emergency shut off when you roll it? I have the shop manual and it does not mention it at all.....
Anybody know what it is and if maybe it's the problem?

Restrorob
07-27-2007, 11:16 PM
That's a fuel cut-off solenoid and shuts the fuel flow off from the main jet. It's supposed to help keep the engine from back firing on shut down. I would say that's not your problem since it is running.

Drive the unit with the blades engaged across flat ground then slowly start applying the choke and see if it runs any better. If it does there is either a vacuum leak or something still partly restricted inside the carb.

hess
07-28-2007, 01:28 PM
Try the fuel filter