PDA

View Full Version : Shindaiwa Hedge Trimmer won't accelerate


jondcoleman
07-26-2007, 04:34 PM
I bought a new Shindaiwa Hedge Trimmer about a month ago and now it won't accelerate. It idles fine but when I hit the throttle anything above barely idling it breaks. Any suggestions? BTW I took out the spark arrestor.

The throttle cable came broken so I had to change that but I don't know how that would have affected it. Thanks!

Jon

MowerMedic77
07-26-2007, 06:09 PM
I bought a new Shindaiwa Hedge Trimmer about a month ago and now it won't accelerate.
The throttle cable came broken so I had to change that but I don't know how that would have affected it. Thanks!

Jon

This unit is still under warranty:confused: Who replaced the cable? Is it pulling the throttle barrel open completely?
Pulling the spark arrestor would have been my first thought for low rpms and one month seems too soon to have carbon built up in the exhaust port but stranger things have happened.

khouse
07-26-2007, 06:27 PM
If you have clean fuel in it and you can see the throttle working then take it back.

Breezmister
07-26-2007, 08:45 PM
I bought a new Shindaiwa Hedge Trimmer about a month ago and now it won't accelerate. It idles fine but when I hit the throttle anything above barely idling it breaks.

Don't know what you mean by "breaks" but I would get some PB Blaster
and soak the blades, let it set for a while (10/15 minutes) and then try again.
Sap will build up on the blades and get sticky. If this doesn't work, take it back to the dealer