PDA

View Full Version : Turns signals & Brake lights don't work but running lights do on trailer.


RedMax Man
07-29-2007, 09:52 PM
My open trailer has the simple 4way wiring but only the running lights are working, not the turn signals or brake lights. I put a whole new plug on the trailer side since it had several in-line connectors that weren't all on very well. I also put and brand new plug on the truck side. Still doesn't work.
All trailer light bulbs work except for one of the 3 middle lights thats bellow the tailgate. I looked at all the wiring underneath trailer and nothing appears to be damaged. Does the truck have a problem or is in the trailer? As far as i know the truck is fine because it works with my father's encl. trailer that has the 7way wiring. Anybody got knowledge on this?
Thanks.

meathead1134
07-29-2007, 10:01 PM
Check to make sure that it is grounded properly. If it is start at the source the truck with a light testor and check the plug on the truck, each turn signal and brake and then just work your waay back. It is actually very simple to do so. I wired my truck and trailer in about a half hour tops.

gavin478
07-29-2007, 11:37 PM
Check the fuse box in your truck. That could be the problem also.

RedMax Man
07-30-2007, 10:46 PM
Thanks guys i found the problem, several of the wires were frayed where they connect to the tail light bulbs. The tail lights were not in the best shape, had some cracked covers and were old.

I stripped the whole trailer down and rewired everything and replaced all tail lights and corner lights with LED lighting. Also replaced the middle clearance light below the ramp tailgate with 60" LED strip light that has stop, tail, and turn signals. Everything works.

SiteSolutions
07-30-2007, 11:26 PM
Thanks guys i found the problem, several of the wires were frayed where they connect to the tail light bulbs. The tail lights were not in the best shape, had some cracked covers and were old.

I stripped the whole trailer down and rewired everything and replaced all tail lights and corner lights with LED lighting. Also replaced the middle clearance light below the ramp tailgate with 60" LED strip light that has stop, tail, and turn signals. Everything works.

How about a Pic???

P.Services
07-30-2007, 11:31 PM
i bet the new leds are so bright you have to squint, i love em

RedMax Man
07-31-2007, 09:47 AM
How about a Pic???

I'll get some pics up and put them in the pic forum. They look sweet and are extremely bright!

mike33087
07-31-2007, 10:58 PM
mine did that and i replaced the bulbs and everything worked again