PDA

View Full Version : High Lifts slow motor?


rjprice
07-31-2007, 12:21 AM
I'm a homeowner with a 2006 Scag Tiger Cub. I just replaced my original equipment low-lift blades with high-lifts. It seems to bog down in really high grass, now. Is this normal? It seems the drag would be higher due to the much larger sail on the blades but I was not sure. Any ideas????

captken
07-31-2007, 12:34 AM
I'm a homeowner Any ideas????

yeah, post it here. http://www.lawnsite.com/forumdisplay.php?f=3 homeowner assistance forum.

cheers!

chammons
07-31-2007, 12:41 AM
The high lift blades are creating more vac and it is keeping the grass in the deck and not discharging as efficently as the mid or low lift blades. One question, is the grass also wet? It only happens to me when the grass is wet..not just tall.

rjprice
07-31-2007, 08:37 AM
Yes, the grass is a little wet. It's been raining here in Texas for a month.

jkingrph
07-31-2007, 08:45 AM
I noticed that. I have a Scag Wildcat 52" with 26HP LC Kawasaki. When I put the Oregon high lifts on and hit heavy bahia it does slow down. The grass was dry, but I have been working the last three weeks, 12 hours at my hospital, then mowing after I get home, so am trying to go fast . Slow down a bit and they will straighten the grass up and give a better cut. The way I was going all I wanted to do was knock it down. The regular blades breeze right through with no engine pull down.

chammons
07-31-2007, 10:30 AM
That is what I thought...I am from OK and we are getting the same rain. On sunday we got 3.25" of rain in an hour and a half. So far over 50" this year!!!