PDA

View Full Version : RedMax Trimmer Help


klcArk
07-31-2007, 08:46 PM
We were half way through one of our larger jobs today when the RedMax decided it would bog down at full throttle. Half throttle is cool and anything leading up to it is ok but when you need to get through some tuff stuff it bogs way down like its under a load at full throttle.

I dont know much about two cycle engines. All that I knew to do in the field was to check the air filter. It could use a good cleaning but even with the air filter removed the symptoms remain.

Any ideas on how I can DIY it tonight or is this something for a pro? My local dealer closed his doors and I dont know if anyone else here in this small town will tackle it.

dutch1
07-31-2007, 09:30 PM
If it hasn't been serviced recently---replace the plug, change out the intank fuel filter and check the antispark screen in the muffler for carbon buildup. That's about the only quick DIY info.

Dutch

MJS
07-31-2007, 09:46 PM
Could be the carburetor also. . .

P.Services
07-31-2007, 09:51 PM
you did pull that screen out of the muffler right?

klcArk
08-01-2007, 03:13 PM
Okay. Pulled the plug and cleaned it up. Not the problem. Pulled the gas filter and cleaned it out (even ran without the filter to see what would happen) not the problem. I did a thorough cleaning of the air filter while I was at it.

I couldnt find the screen on the engine side of the muffler so... I ran to a repair shop. They dont work on stuff they dont sell. I asked what to check and they insisted it must be the spark arrestor. Pulled the muffler and took it into the shop. They showed me how to stab it with a screwdriver and remove the screen from the inside of the muffler. No Charge! Gave them a tip, least I could do so I could have two trimmers today.

Thanks guys, you got me in the right direction! :)