PDA

View Full Version : Help, Wright Sentar


garyslawn
08-05-2007, 11:45 AM
When the switch for the blade engage clutch is pulled the engine quits running. Sometimes it will spududder and run for awhile. It finally quit completly. I can hear the clutch kick in and out with engine not running. Cant find a wire broke or grounded. Any ideas. Thanks Gary

cpel2004
08-05-2007, 12:51 PM
Check yout clutch, and look for a short in the wiring.

Bill Kapaun
08-05-2007, 01:42 PM
How long is "awhile"?

"I can hear the clutch kick in and out with engine not running."
On it's own, or with the switch being activated? Or in & out with the switch ON?

"It finally quit completly"
DO you mean it won't start? If so, does it crank over, click, completely dead or....?

There's about 3 paths to follow here- need additional details.
1. Engine quit charging and battery went dead.
2. Fuel filter clogged enough that engine starves for fuel under load.
3. Wiring is "messed up".

garyslawn
08-05-2007, 02:11 PM
Bill; 1.) Clutch kicks in / out as it should with engine shut off. wanted to hear it in and disengauge
2.) engine starts and runs fine untill you pull the blade switch
3.) replaced the switch,same results. Clutch was replaced last year.
4.) Cant find a bad wire. Just got a wiring diagram of the net. THANKS CPEL
Thanks; Gary

Bill Kapaun
08-05-2007, 02:18 PM
Have you checked all the deck pulleys, rotating parts etc. for any binding?

ed2hess
08-05-2007, 05:51 PM
I haven't worked on our Sentar much yet....but could it be a safety switch that isn't failing completely? I think my son had trouble with the one that is located under the plate you stand on.

pugs
08-06-2007, 09:52 AM
Yah, the operator pressence switch is probably the problem. The back of them cracks out and then you get anything from intermittent problems to total failure.