PDA

View Full Version : Toro Mower Maintenance


steve124
08-12-2007, 03:20 PM
Looking for some mower maintenance and where to get parts if needed.

I have a Toro self propelled 6.5 HP recycler and it's 3 years old. I mow my yard only and it's been working fine until today. I'm mowing away and then huge billows of white smoke start kicking out. I put a new plug and filter in two months. I pulled the plug and filter and the filter is dripping oil and the plug is wet. I pull on the starting cord and fluid is coming in on the plug side.

So, obviously I have a bad ring or plug. What's my next step? The manual supplied is only for standard stuff and nothing this detailed. Do I need to pull the head and get a new ring or what?

The unit is only 2 - 3 years old so I'm wondering if there is a warranty but I bet it's done with by now.

Any help on diagnosing the problem or a good on-line parts store would be much appreciated.

Vikings
08-12-2007, 06:00 PM
Mine always seem to puff out white smoke. I think it's from going up ramps and oil leaks into places it's not supposed to be. Plus I've gotten my air filter soaked with oil from turning the mower on the wrong side.

I've also hit the tube that you pour oil into and had the bottom pop out. I was leaking oil out the side.

Not saying any of these are your problems, just throwing around ideas.

http://img.photobucket.com/albums/v242/SubZero2040/poppedout.jpg

http://img.photobucket.com/albums/v242/SubZero2040/generalarea.jpg

Bill Kapaun
08-12-2007, 07:04 PM
If it's an OHV engine, I'd suspect a blown head gasket.

steve124
08-12-2007, 08:16 PM
Yes, sometimes it puffs out some smoke but not much. This was a cloud that got incredibly worse in about 30 seconds so I turned if off before I ruin it completely.

It's a Briggs and Stratton engine and I pulled the plug and could look in the cylinder so when someone would pull the starting cord I would see oil go in where the plug is sitting. I'm thinking a bad ring or a head gasket.

Any other ideas?

lawnboy dan
08-13-2007, 07:20 AM
never seen a quamtum with an oil filter .

steve124
08-13-2007, 07:59 AM
No, oil is getting to the AIR filter.

Any ideas on how to fix this mower?

Bad ring maybe?

All_Toro_4ME
08-13-2007, 10:03 AM
Looking for some mower maintenance and where to get parts if needed.

I have a Toro self propelled 6.5 HP recycler and it's 3 years old. I mow my yard only and it's been working fine until today. I'm mowing away and then huge billows of white smoke start kicking out. I put a new plug and filter in two months. I pulled the plug and filter and the filter is dripping oil and the plug is wet. I pull on the starting cord and fluid is coming in on the plug side.

So, obviously I have a bad ring or plug. What's my next step? The manual supplied is only for standard stuff and nothing this detailed. Do I need to pull the head and get a new ring or what?

The unit is only 2 - 3 years old so I'm wondering if there is a warranty but I bet it's done with by now.

Any help on diagnosing the problem or a good on-line parts store would be much appreciated.

Hey steve124, you may try sending restorerob a private message. Hes very knowledgable in mowers.

Bill Kapaun
08-13-2007, 04:07 PM
Since you have an engine problem, you MIGHT actually specify WHICH engine! Model numbers!