PDA

View Full Version : Yamaha Engine Sputtering


Mack77
12-10-2007, 05:23 PM
Hello all!

I have a Yamaha Grizzly 600cc 4 wheeler that we use to do leaf cleanups. The machine runs and works great for pulling a tarp full of leaves...however there is a problem w/ the engine...

The problem is, at random times when you open up the throttle all the way (not pulling a tarp when doing this!) The machine will sputter and loose ALL power. If you gas it, the machine will sound like it will stall and backfire, however if you wait about 10 seconds without opening the throttle, the machine will run perfectly again for a few more minutes then the problem will repeat.

Any ideas? :confused:

topsites
12-12-2007, 01:15 AM
That sounds like the old carbureted cars back in the days, when they did that it was said to be flooding...
As in, the engine simply is getting either too much fuel or too much air some kind of way, and it chokes on it.
Because it's unmetered, the carb simply opens up its mouth and the engine sucks in whatever happens to come that way.

So somewhere, somehow the fuel / air mixture going into the cylinder(s) isn't being properly combusted.

A dirty air filter could cause it, spark plugs might need replacing, fuel filter could be the culprit, I'd replace all of that for starters, check for improvement after each step.

Beyond that maybe a dirty carb or clogged jets or a sticking float, I'd clean the linkages good and also check the choke mechanism and make sure the valve stays open.

Just for kicks you might replace the ignition switch as well, at least make sure all the connections are good.
Then it might be the coil not delivering sufficient power.
Sorry, I know.
Just do one thing at a time, start with the cheapest.

Now if all that doesn't fix it one work-around is to gas it gradually and let the engine catch up, takes a bit of practice.