PDA

View Full Version : Repair exmark wheel motor


chesterlawn
01-07-2008, 04:17 PM
I had my lazer wheel motor replaced because it was starting to leak out of the seal. It was running fine, so I'm thinking of replacing the front bearing and the seal on my old one. My question is how do I get the bearing out, do I take the whole pump apart? It's a ross pump about 11 yrs old . mb150208cccg, ccmb240, d/c239 976 d Thanks

ed2hess
01-07-2008, 09:02 PM
The Ross I had on the Scag had to be taken apart. Then you can pull the bearing with a bearing puller.....I took mine to a shop that works on hydro units. The problem is the shaft that rotates inside the bearing can be damaged a small amount and as a result the oil seal won't seal it up for very long. We would all be wise to replace these darn bearing(which are cheap) before they start leaking. So you will need a seal kit plus the bearing and be sure to clean the corrosive preventer out the bearing before you put in the grease.

DiyDave
01-07-2008, 09:29 PM
Take it to a shop that rebuilds hydraulic pumps and motors, they have the tools to dismantle and re assemble without damaging parts. They also have the experience to do it right. There is a rebuilder in your area, look up advanced fluid systems. I used them a couple of times, no complaints. That name may have changed, but the shop down here by BWI airport sent stuff out to Lancaster, PA, so chance are, they are still in business.:waving:

chesterlawn
01-08-2008, 02:03 PM
Thanks for your help.