PDA

View Full Version : 17hp Vanguard how do you increase RPM


Daves
10-27-2001, 11:20 PM
I have a 17 hp vanguard how to you increase the engine RPM's

Robert Doubrava
10-27-2001, 11:37 PM
does it run bad? too slow? i would think you should adjust the high speed screw on the carb.

Daves
10-28-2001, 07:40 AM
Yes it running slow It's only 2 yrs old it has no high limit screw on it I believe it is preset at factory

Robert Doubrava
10-28-2001, 09:49 AM
im not sure, but i would think that the governor should be adjusted somehow.

thfireman
04-09-2003, 12:13 AM
I need the same info. I think the carb needs adjusting some how, But I cant find any help on this subject.

Robert Doubrava
04-10-2003, 09:00 PM
I'll look for that info on my Briggs CD rom repair manual, I'll see if there is any related info in it. If I do find it I'll let you guys know.

Robert

thfireman
04-11-2003, 08:20 AM
Thanks Robert! :)

Robert Doubrava
04-11-2003, 04:44 PM
No problem, all I need is the model numbers off your engine!

Robert:)

John DiMartino
04-12-2003, 11:38 PM
Daves,do not increase the RPM based on sound,the Briggs Vanguards are very smooth and quiet. I thought mine was set to slow also,but i checked it with a handheld RPM tachometer,the RPMS were perfect,the engine just sounds like its loafing along,where as my Kohler at the same speed sounds like its coming unglued.

mikemerritt
04-13-2003, 06:53 AM
Make sure the throttle is moving all the way open. If the RPM's are correct (and they probably are) any attempt to gain RPM's via the governor will cause a lean situation with no high speed screw.....Mike

Doc Pete
04-13-2003, 07:43 AM
FWIW, all you have to do increase RPM is bend the tab that holds throttle spring and increase the tension. Becareful, you don't have to move it alot. Use a tach. Also, I've taked to the B&S technicans and they've had motors running at 4,000 all the time with no problems, plus you don't have to worry about any lean problems (according to them). Finally, I ran my 16 and 20 horse Briggs for three years at 3,850 prm without any probems, in fact they were a bit smoother.........
Pete

Robert Doubrava
04-17-2003, 11:02 PM
I looked in my manual and it says one reason for the engine running "slow" is that one cylinder has lost compression. That might not have happened, though. To check just get a compression tester and crank it over a few times and note the PSI on one cylinder and check the other. If you got it fixed already, disregard this!:)

Robert