PDA

View Full Version : 721 Grasshopper hydrostatic transmission


crichards
04-07-2008, 08:35 PM
I have a 721 Grasshopper that has 1000 hours. The left hydrostatic transmission does not have any power reversing. It will barely move the mower backwards. It, however, seems to be just fine moving forward. Is this just the process of the drive going out or is there something else I need to check that could be causing the problem. I just recently changed oil and filters on the transmissions. I checked on price of new hydrostatic transmission, about $1100. Are there kits I could possibly buy and repair myself or is it required skilled workmanship? Any suggestions are appreciated.

khouse
04-08-2008, 09:29 AM
Was it working good before you changed the fluid? Make sure your getting good travel on the lever at the tranny? Compare it with the travel from the good side.

crichards
04-08-2008, 08:36 PM
I had not noticed any big difference between the two transmissions, before oil change. I had sprayed about 7-9 acres with the new oil change and did not notice this beginning to happen. I have to think I was just not in a situation to notice that it was weakening, but not sure. I did make a visual observation of linkage and do not see any difference between the two linkages. I took off the new filter on that side and put it back on, looking for possible blockage, etc, just trying anything.
Is it usual that the transmission would weaken only in one direction (backwards) and not the same amount of weakening in the forward direction?
Is it usually a gradual process?
Thanks.