View Full Version : Snapper czt19480kwv no spark

bill bass
04-08-2008, 07:40 PM
Worked fine when I parked it last fall. Pulled a spark plug, left the boot on, grounded it against engine and cranked it over. Saw no spark. Getting gas- leaking from muffler pipe. Any suggestions as to common causes ?


04-08-2008, 09:01 PM

It's most likely a bad contact inside one of the safety switches, You can disconnect the purple wire as below then check for spark again. This will eliminate the engine/coils being the problem.

As for fuel coming out of the muffler, Sounds like the carb float needle valve is not seating or is stuck. May need to tear it down and clean it out.


bill bass
04-08-2008, 10:42 PM
Looks like you saved me again. Thanks for your input. I'll check on it. Going to rain here through the weekend.

bill bass
04-11-2008, 08:39 PM
Or, I suppose, I could have alzhiemers and did not set the brake before trying to start it.

Thanks for your time and assistance


04-11-2008, 09:32 PM
did not set the brake before trying to start it.

Don't you just love Snapper for doing that ? They are about the only ones that have the brake/clutch switch wired to crank over but not let spark....:hammerhead:

bill bass
04-12-2008, 06:31 PM
I am almost certain that I used to be able to start this without engaging the parking brake. Oh well, your guidance was what pointed the way to me. I appreciate the help


Jay Ray
04-12-2008, 08:12 PM
It's spring. I couldn't start my Kee trailmower yesterday. Forgot I had put a shutoff valve on it and run it dry. Used up about half of what's left in my right shoulder:hammerhead: The diagnosis was difficult but the fix was easy.