PDA

View Full Version : Another Kohler carb issue


dkeisala
04-22-2008, 07:29 PM
Kohler CH20S-64660 on a Walker mower. Runs great at full throttle but refuses to idle. Done to date:

1) Disassembled and cleaned carb
2) Replaced fuel filter
3) Cleaned screen on intake tube in fuel tank
4) Adjusted float to spec
5) Adjusted idle speed screw
6) Check all hoses and lines for condition

Engine seems to be flooding out at idle, hard re-start. Fuel is also getting into crankcase. Fuel pump appears to be working just fine but fuel filter refuses to fill completely. Could the pump be working sufficiently at full speed but not at idle? Could the selenoid need replacing? I'm at wits end and any suggestions would be much appreciated.

Restrorob
04-22-2008, 07:57 PM
Engine seems to be flooding out at idle, hard re-start. Fuel is also getting into crankcase.


Replace the float needle valve, It sounds like it's not fully seating. And of course change the oil after doing so.

dkeisala
04-22-2008, 08:22 PM
I think I may have found the problem. I didn't take the fuel pump completely apart, just checked to see if it was operating. After removing the 4 screws holding the rocker arm, spring and pump in place I noticed one of the two square gaskets worn away and torn so I ordered a new fuel pump, was told they don't make a rebuild kit. Hopefully that fixes the problem.

Restrorob
04-22-2008, 08:39 PM
Yeah your right, That should solve the problem. I didn't punch your numbers in before replying.....

GravelyNut
04-22-2008, 11:23 PM
I think I may have found the problem. I didn't take the fuel pump completely apart, just checked to see if it was operating. After removing the 4 screws holding the rocker arm, spring and pump in place I noticed one of the two square gaskets worn away and torn so I ordered a new fuel pump, was told they don't make a rebuild kit. Hopefully that fixes the problem.
It used to be nice when you could get the kits to rebuild the pumps. Now I think the only one that can be rebuilt are the ones on the Onan B43M and B48M carbs. :( A sign of progress.:rolleyes:

VegetiveSteam
04-24-2008, 02:26 PM
If the fuel pump doesn't fix it check the flywheel key. A fuel pump would probably give you more of a problem at high speed than low.

dkeisala
04-24-2008, 03:36 PM
Unless that pump was moving up and down fast enough to deliver enough power at high speed but wasn't able to deliver enough fuel pressure at low speed to maintain idle. The gasket is completely trashed, I'm actually surprised it worked at all.

tomo
04-25-2008, 05:47 AM
hello
check the low speed emulsion tube has been inserted back into the carb main body the correct way round refer a manual . The o rings easily fall apart over time and also when it is disturbed,
This part is on the top of the main body when top housing is removed

tomo:waving:

dkeisala
04-25-2008, 11:18 AM
hello
check the low speed emulsion tube has been inserted back into the carb main body the correct way round refer a manual . The o rings easily fall apart over time and also when it is disturbed,
This part is on the top of the main body when top housing is removed

tomo:waving:

Is this the part the manual refers to as the breather tube? If so, it's all cracked and deteriorating too. Ordered a new one of those as well.