PDA

View Full Version : Engine will only run when choked


kernopelli
04-26-2008, 12:27 PM
I just got done rebuilding an old B&S 18 HP opposed twin. Many thanks to the help I received on this board! It starts up fine, idles smooth, throttles up and sounds great until you take the choke off, then it falls on its face. I have adjusted the governor and am pretty confident I have it correct. Fresh gas and filter of coarse and I have checked for intake leaks and cleaned the carb. I adjusted the mixture screw and it will run at low RPMs without choke but not 1/2 - full throttle without choke. I did check the fuel shut off solenoid and it is getting voltage and the plunger moves easily to the touch but when I had the carb apart I hooked the wire to it and grounded the side to the mower frame and cranked the engine over but could not tell that the plunger moved at all. Any ideas on what I'm missing??

Bill Kapaun
04-26-2008, 04:59 PM
You should hear a distnict "click" when the solenoid engages.

kernopelli
04-26-2008, 06:31 PM
Thanks. I checked the solenoid again and it is definitely kaput. I started searching the net again and saw that the solenoid is not essential so I took it off and blocked it with a bolt and o ring. It seemed to have helped and I played with the mixture screw again and got it running perfect. Put the air cleaner back on....same thing again.
Messed with the adjustment screw some more and got it running great with the air cleaner on and no choke. AHH perfection! Mowed some and went in the eat some lunch.
Let it sit an hour and went out and started it up and it started dying at high throttle again. Backed the "solenoid replacement" screw out and it ran great again. Sat another hour and when restarted it wouldn't run at full throttle. Messed with it more ( mixture screw and backed out the "solenoid replacement bolt" and as soon as I think I have it dialed in, I put the air cleaner on and it is choked off at high rpm's again.
I think I know what I need to do now.......cold beer and dynamite will make this all go away;).
But seriously...any more ideas????????????

Tom Tom
04-26-2008, 06:58 PM
sounds like something in the carb pickup tube- carb jet has a partial blockage

Bill Kapaun
04-26-2008, 07:56 PM
Agree with Tom Tom.
Maybe water in the tank/ gas can?

kernopelli
04-26-2008, 11:35 PM
Agree with Tom Tom.
Maybe water in the tank/ gas can?

Makes sense. I will check it tomorrow. Funny how you get so caught up in something you forget to look at the obvious. Normally, those would have been the first thing I looked at but somehow got lost in a forest with very few trees.
Thanks Men.
Darryl

Accu-cut Lawn Care
04-27-2008, 12:33 PM
It may be that your high speed needle is clogged. If bad gas is not the cause, you may have some varnish in the carb.

kernopelli
04-27-2008, 07:24 PM
Thanks for all the replies.
I went out first thing this afternoon and was going to clean the carb (again) and clean the fuel tank and put some SeaFoam in the gas and when I was taking the air cleaner assembly off, I noticed the gasket between the carb and filter housing was askew and was blocking an orifice. I reset the gasket and put the housing/filter back on and PRESTO! We're in business!!!! Mowed about an hour and it is running great.
I really appreciate the community here. I have been reading the discussions for the last few months and have learned a lot and really enjoy all the info and help this site offers

Darryl.