PDA

View Full Version : Hydro pumps/wheel motors are going out?


Bunton Guy
04-30-2008, 09:03 PM
How do you know when a hydro pump or wheel motor is going out? other than them not going forward or reverse.

I have a 03 great dane 60" with 23 kawi that we have put 1,300 somewhat trouble free hours on until now.

Seems that the right side hydro is acting up. While going full blast forward I can completly let go of the right side hydro and the mower will continue on straight forward....yes I have checked to see if the arm on the pump is going back to the neutral position and it does! The right side hydro does not want to back up much if at all. The mower does track pretty straight when going so I don't think its an adjustment....although I have tried adjusting it many different ways making it only worse. Also the right side control/pump has alot of slop in it. I can push the hydro arm roughly 3-3.5" forward before that right side wheel actually does anything. The right side wheel will not slow down from forward motion by simply bringing the right side control back to the neutral position like you normally would which makes for a jerky ride.

I should have been more proactive as the complete right side of the mower is covered in hydro oil! I thought it was just a leaking filter (which does leak!) I can't tell if the hoses are leaking or not. Recently the oily mess went from fresh oil every day to now the dust & dirt has collected on it so im guessing whatever was leaking has stopped.

Fluid levels are checked daily and are topped off if needed. Lately it hasen't needed any. Does this sound like I might be able to buy a seal kit and nurse this hydro pump back to health? What is the signs of a bad pump & or wheel motor. Do they both go out togather? :walking: :dizzy: :cry:

Bunton Guy
05-01-2008, 09:45 AM
J-thomas has a o-ring kit for my hydro pumps. Should I try to take it apart and re-oring and see if that works? It seems like the pump still works but it does not have the normal pressure that it should...maybe like something is leaking pressure

frustrated
05-01-2008, 10:15 AM
If the pump isnt making the pressure it should be, you need to take it and have it rebuilt, along with replacing the hydro oil since you dont know what kind of metal shavings or crap may be in there.