PDA

View Full Version : CGC Bobcat 227- Hydrogear pump leak


KatKutter
05-22-2008, 12:44 AM
While doing service on the equipment this past weekend. I noticed just a slight sticky film on underside of mower. After a closer look its seems that the bottom seal of the left hand pump must be leaking ever so slightly. Not enough to drip, but just enough for debris to cling. Just wondering has anyone ever attempted to put a seal kit in one of these pumps. At $450.00 each I would much rather try a $20.00 seal kit. The pump works fine, just trying to avoid what is comeing if I dont fix it. Down time kills this time of year. Any info would be greatly appreciated.

MJB
05-22-2008, 01:45 AM
While doing service on the equipment this past weekend. I noticed just a slight sticky film on underside of mower. After a closer look its seems that the bottom seal of the left hand pump must be leaking ever so slightly. Not enough to drip, but just enough for debris to cling. Just wondering has anyone ever attempted to put a seal kit in one of these pumps. At $450.00 each I would much rather try a $20.00 seal kit. The pump works fine, just trying to avoid what is comeing if I dont fix it. Down time kills this time of year. Any info would be greatly appreciated.

Are you sure it is the seal and not a line that has come loose. Make sue all the lines are dry I had one back off recently I just tightened it up a tiny bit and it stopped.

themowerman
05-22-2008, 09:12 AM
Might also be residule oil from oil changes...................

KatKutter
05-22-2008, 11:30 PM
Its a leak guys. Done checked everything else. but thanks for the info. And the 27 kohler likes oil, new machine but I think there is a problem with some of the 27's. I have heard others with the same issue. Pump leak and oil drinker (lol). Dont ya just love cutting grass and dealing with stuff like this all the time.

KatKutter
06-03-2008, 12:06 AM
Fixed it. Seal kit was 22.00. Drop the pump pully, remove retainer snap ring, drywall screw into the seal and pull it out with pliers. Just always keep pushing up on the shaft, or it will fall out and so do the bearing. Then you have to take the whole thing off and apart and make a 10 min. job about a 5 hour one (lol). Guess now i no to hold the shaft in after i remove the seal hu... Anyways it all worked out and got it back together. Those pumps are really not that bad inside, you just really got alot of tiny pieces to keep up with. But it was pretty simple, getting the thing off and out, and back in was the hard part. If I ever have to do it again, now I no to hold that dang shaft in place.